[brcm63xx] refresh 2.6.32 patches
[openwrt.git] / target / linux / brcm63xx / patches-2.6.32 / 170-board_livebox.patch
index 6cf3f718239be11a26a1f98b54ab09f352cc04f2..02354d573c04b46edff9ae733b4dddbdf96157a0 100644 (file)
@@ -1,8 +1,6 @@
-Index: linux-2.6.32.9/arch/mips/bcm63xx/boards/Kconfig
-===================================================================
---- linux-2.6.32.9.orig/arch/mips/bcm63xx/boards/Kconfig       2010-02-28 19:03:38.000000000 +0100
-+++ linux-2.6.32.9/arch/mips/bcm63xx/boards/Kconfig    2010-02-28 19:04:38.000000000 +0100
-@@ -8,4 +8,10 @@
+--- a/arch/mips/bcm63xx/boards/Kconfig
++++ b/arch/mips/bcm63xx/boards/Kconfig
+@@ -8,4 +8,10 @@ config BOARD_BCM963XX
        select SSB
         help
  
@@ -13,20 +11,16 @@ Index: linux-2.6.32.9/arch/mips/bcm63xx/boards/Kconfig
 +       Inventel Livebox boards using the RedBoot bootloader.
 +
  endchoice
-Index: linux-2.6.32.9/arch/mips/bcm63xx/boards/Makefile
-===================================================================
---- linux-2.6.32.9.orig/arch/mips/bcm63xx/boards/Makefile      2010-02-28 19:03:45.000000000 +0100
-+++ linux-2.6.32.9/arch/mips/bcm63xx/boards/Makefile   2010-02-28 19:04:54.000000000 +0100
+--- a/arch/mips/bcm63xx/boards/Makefile
++++ b/arch/mips/bcm63xx/boards/Makefile
 @@ -1,3 +1,4 @@
  obj-$(CONFIG_BOARD_BCM963XX)          += board_bcm963xx.o
 +obj-$(CONFIG_BOARD_LIVEBOX)           += board_livebox.o
  
  EXTRA_CFLAGS += -Werror
-Index: linux-2.6.32.9/arch/mips/bcm63xx/boards/board_livebox.c
-===================================================================
---- /dev/null  1970-01-01 00:00:00.000000000 +0000
-+++ linux-2.6.32.9/arch/mips/bcm63xx/boards/board_livebox.c    2010-02-28 19:05:16.000000000 +0100
-@@ -0,0 +1,227 @@
+--- /dev/null
++++ b/arch/mips/bcm63xx/boards/board_livebox.c
+@@ -0,0 +1,223 @@
 +/*
 + * This file is subject to the terms and conditions of the GNU General Public
 + * License.  See the file "COPYING" in the main directory of this archive
@@ -42,15 +36,14 @@ Index: linux-2.6.32.9/arch/mips/bcm63xx/boards/board_livebox.c
 +#include <linux/mtd/mtd.h>
 +#include <linux/mtd/partitions.h>
 +#include <linux/mtd/physmap.h>
++#include <linux/input.h>
++#include <linux/gpio_buttons.h>
 +#include <asm/addrspace.h>
 +#include <bcm63xx_board.h>
 +#include <bcm63xx_cpu.h>
 +#include <bcm63xx_regs.h>
 +#include <bcm63xx_io.h>
-+#include <bcm63xx_board.h>
 +#include <bcm63xx_dev_pci.h>
-+#include <bcm63xx_dev_uart.h>
-+#include <bcm63xx_dev_wdt.h>
 +#include <bcm63xx_dev_enet.h>
 +#include <bcm63xx_dev_pcmcia.h>
 +#include <bcm63xx_dev_usb_ohci.h>
@@ -222,9 +215,6 @@ Index: linux-2.6.32.9/arch/mips/bcm63xx/boards/board_livebox.c
 +{
 +      u32 val;
 +
-+      bcm63xx_uart_register();
-+      bcm63xx_wdt_register();
-+
 +      if (board.has_pccard)
 +              bcm63xx_pcmcia_register();
 +
@@ -248,7 +238,7 @@ Index: linux-2.6.32.9/arch/mips/bcm63xx/boards/board_livebox.c
 +      val &= MPI_CSBASE_BASE_MASK;
 +      mtd_resources[0].start = val;
 +      mtd_resources[0].end = 0x1FFFFFFF;
-+      
++
 +      platform_device_register(&mtd_dev);
 +
 +      return 0;