rename the Profile template that the image builder uses to prevent name conflicts...
[openwrt.git] / target / linux / brcm-2.6 / Makefile
index c30e150f4af60d67c3202d4cccf6f5181e8fab19..8b135072c3bcbb7f2fa4c539edf766e4cee7ca6e 100644 (file)
@@ -13,30 +13,40 @@ FEATURES:=squashfs
 
 define Target/Description
        Build firmware images for Broadcom based routers
-       (e.g. Linksys WRT54G(S), Asus WL-500g, Motorola WR850G)
-
-       This one builds the generic .trx images, activate one of the
-       options below for creating device specific files for use
-       with TFTP client too.
+       (e.g. Netgear WGT634U)
 endef
 
-LINUX_VERSION:=2.6.19.1
-LINUX_RELEASE:=1
-LINUX_KERNEL_MD5SUM:=2ab08fdfddc00e09b3d5bc7397d3c8be
-
 include $(INCLUDE_DIR)/kernel-build.mk
-DEFAULT_PACKAGES += kmod-switch
+DEFAULT_PACKAGES += kmod-switch kmod-diag
 
 define Profile/Atheros
   NAME:=Atheros WiFi (default)
   PACKAGES:=kmod-madwifi
 endef
+
+define Profile/Atheros/Description
+       Package set compatible with hardware using Atheros WiFi cards
+endef
 $(eval $(call Profile,Atheros))
 
+define Profile/WGT634U
+  NAME:=Netgear WGT634U
+  PACKAGES:=kmod-madwifi kmod-usb-core kmod-usb-ohci kmod-usb2
+endef
+
+define Profile/WGT634U/Description
+       Package set compatible with the Netgear WGT634U. Contains USB support
+endef
+$(eval $(call Profile,WGT634U))
+
 define Profile/None
   NAME:=No WiFi
   PACKAGES:=
 endef
+
+define Profile/None/Description
+       Package set without WiFi support
+endef
 $(eval $(call Profile,None))
 
 $(eval $(call BuildKernel))