rename the Profile template that the image builder uses to prevent name conflicts...
[openwrt.git] / target / linux / brcm-2.6 / Makefile
index 0d5533194eca499854e7189cdc272d15161cd3c5..8b135072c3bcbb7f2fa4c539edf766e4cee7ca6e 100644 (file)
@@ -13,7 +13,7 @@ FEATURES:=squashfs
 
 define Target/Description
        Build firmware images for Broadcom based routers
-       (e.g. Linksys WRT54G(S), Asus WL-500g, Motorola WR850G)
+       (e.g. Netgear WGT634U)
 endef
 
 include $(INCLUDE_DIR)/kernel-build.mk
@@ -29,6 +29,16 @@ define Profile/Atheros/Description
 endef
 $(eval $(call Profile,Atheros))
 
+define Profile/WGT634U
+  NAME:=Netgear WGT634U
+  PACKAGES:=kmod-madwifi kmod-usb-core kmod-usb-ohci kmod-usb2
+endef
+
+define Profile/WGT634U/Description
+       Package set compatible with the Netgear WGT634U. Contains USB support
+endef
+$(eval $(call Profile,WGT634U))
+
 define Profile/None
   NAME:=No WiFi
   PACKAGES:=