rename the Profile template that the image builder uses to prevent name conflicts...
[openwrt.git] / target / linux / brcm-2.6 / Makefile
index 0a2575913d44f6f3e3c927d26db5351ea5ec7f9f..8b135072c3bcbb7f2fa4c539edf766e4cee7ca6e 100644 (file)
@@ -13,7 +13,7 @@ FEATURES:=squashfs
 
 define Target/Description
        Build firmware images for Broadcom based routers
-       (e.g. Linksys WRT54G(S), Asus WL-500g, Motorola WR850G)
+       (e.g. Netgear WGT634U)
 endef
 
 include $(INCLUDE_DIR)/kernel-build.mk
@@ -23,12 +23,30 @@ define Profile/Atheros
   NAME:=Atheros WiFi (default)
   PACKAGES:=kmod-madwifi
 endef
+
+define Profile/Atheros/Description
+       Package set compatible with hardware using Atheros WiFi cards
+endef
 $(eval $(call Profile,Atheros))
 
+define Profile/WGT634U
+  NAME:=Netgear WGT634U
+  PACKAGES:=kmod-madwifi kmod-usb-core kmod-usb-ohci kmod-usb2
+endef
+
+define Profile/WGT634U/Description
+       Package set compatible with the Netgear WGT634U. Contains USB support
+endef
+$(eval $(call Profile,WGT634U))
+
 define Profile/None
   NAME:=No WiFi
   PACKAGES:=
 endef
+
+define Profile/None/Description
+       Package set without WiFi support
+endef
 $(eval $(call Profile,None))
 
 $(eval $(call BuildKernel))