ixp4xx 2.6.26 support
[openwrt.git] / target / linux / atheros / patches-2.6.24 / 110-spiflash.patch
index fc4ef4c0f230e38530b1bb97cd84f3da480ab9f0..1e40a6b60340bcbf967d768712f755bc534c9f4e 100644 (file)
@@ -1,9 +1,10 @@
-diff -urN linux.old/drivers/mtd/devices/Kconfig linux.dev/drivers/mtd/devices/Kconfig
---- linux.old/drivers/mtd/devices/Kconfig      2007-02-04 04:30:26.145338240 +0100
-+++ linux.dev/drivers/mtd/devices/Kconfig      2007-02-02 23:48:28.748969000 +0100
-@@ -76,6 +76,10 @@
-         used for program and data storage.  Set up your spi devices
-         with the right board-specific platform data.
+Index: linux-2.6.24.7/drivers/mtd/devices/Kconfig
+===================================================================
+--- linux-2.6.24.7.orig/drivers/mtd/devices/Kconfig
++++ linux-2.6.24.7/drivers/mtd/devices/Kconfig
+@@ -77,6 +77,10 @@ config MTD_M25P80
+         if you want to specify device partitioning or to use a device which
+         doesn't support the JEDEC ID instruction.
  
 +config MTD_SPIFLASH
 +      tristate "Atheros AR2315/6/7 SPI Flash support"
@@ -12,11 +13,12 @@ diff -urN linux.old/drivers/mtd/devices/Kconfig linux.dev/drivers/mtd/devices/Kc
  config MTD_SLRAM
        tristate "Uncached system RAM"
        help
-diff -urN linux.old/drivers/mtd/devices/Makefile linux.dev/drivers/mtd/devices/Makefile
---- linux.old/drivers/mtd/devices/Makefile     2007-02-04 04:30:26.146338088 +0100
-+++ linux.dev/drivers/mtd/devices/Makefile     2007-02-02 23:48:28.749969000 +0100
-@@ -18,3 +18,4 @@
+Index: linux-2.6.24.7/drivers/mtd/devices/Makefile
+===================================================================
+--- linux-2.6.24.7.orig/drivers/mtd/devices/Makefile
++++ linux-2.6.24.7/drivers/mtd/devices/Makefile
+@@ -17,3 +17,4 @@ obj-$(CONFIG_MTD_LART)               += lart.o
+ obj-$(CONFIG_MTD_BLOCK2MTD)   += block2mtd.o
  obj-$(CONFIG_MTD_DATAFLASH)   += mtd_dataflash.o
- obj-$(CONFIG_MTD_DATAFLASH26) += at91_dataflash26.o
  obj-$(CONFIG_MTD_M25P80)      += m25p80.o
 +obj-$(CONFIG_MTD_SPIFLASH)    += spiflash.o