generic: rtl8366_smi: only assign pvid if no pvid was set yet
[openwrt.git] / target / linux / at91 / Makefile
index 2f86b311d0ceb627163615e11abc4e172c9afef3..3c7d85bda72f801d9db937b05c407d7935075a34 100644 (file)
@@ -8,19 +8,18 @@ include $(TOPDIR)/rules.mk
 
 ARCH:=arm
 BOARD:=at91
-BOARDNAME:=NetusG20
-FEATURES:=squashfs jffs2 tgz
-CFLAGS:=-Os -pipe -march=armv5te -mtune=arm926ej-s -funit-at-a-time
+MAINTAINER:=Claudio Mignanti <c.mignanti@gmail.com>
+BOARDNAME:=Atmel AT91
+FEATURES:=squashfs jffs2 targz ext2 usb
+CFLAGS:=-Os -pipe -march=armv5te -mtune=arm926ej-s -fno-caller-saves
+SUBTARGETS:=9g20 9260 9263
 
-LINUX_VERSION:=2.6.34
+LINUX_VERSION:=3.3.8
 DEVICE_TYPE=
 
 include $(INCLUDE_DIR)/target.mk
 
+DEFAULT_PACKAGES+= kmod-usb-ohci
 KERNELNAME:="uImage"
 
-define Target/Description
-       Build firmware images for Acmesystems NetusG20 board
-endef
-
 $(eval $(call BuildTarget))