generic: ar8216: simplify ar8216_config_init
[openwrt.git] / target / linux / at91 / Makefile
index d37aa5378373161b8ea8c65cfc79814032b1f570..1d65d750d9e27f3f57faa1fa725ebe3bfbb582a1 100644 (file)
@@ -8,19 +8,18 @@ include $(TOPDIR)/rules.mk
 
 ARCH:=arm
 BOARD:=at91
+MAINTAINER:=Claudio Mignanti <c.mignanti@gmail.com>
 BOARDNAME:=Atmel AT91
 FEATURES:=squashfs jffs2 targz
-CFLAGS:=-Os -pipe -march=armv5te -mtune=arm926ej-s -funit-at-a-time
+CFLAGS:=-Os -pipe -march=armv5te -mtune=arm926ej-s -fno-caller-saves
+SUBTARGETS:=netus tqma9263 flexibity
 
-LINUX_VERSION:=2.6.34.1
+LINUX_VERSION:=2.6.38.8
 DEVICE_TYPE=
 
 include $(INCLUDE_DIR)/target.mk
 
+DEFAULT_PACKAGES+= kmod-usb-ohci
 KERNELNAME:="uImage"
 
-define Target/Description
-       Build firmware images for Acmesystems NetusG20 board
-endef
-
 $(eval $(call BuildTarget))