[ar71xx] add support for Macronix mx25lxxx flash chips, based on a patch by Jonas...
[openwrt.git] / target / linux / ar71xx / patches-2.6.26 / 001-ar71xx_core.patch
index 229387c1ab16bf3707af7b82da9bb31a917b920b..0ead6d29bc3605fa704145be0f89034e19898e22 100644 (file)
@@ -1,6 +1,6 @@
 --- a/arch/mips/Makefile
 +++ b/arch/mips/Makefile
-@@ -597,6 +597,13 @@
+@@ -597,6 +597,13 @@ core-$(CONFIG_TOSHIBA_RBTX4938) += arch/
  cflags-$(CONFIG_TOSHIBA_RBTX4938) += -Iinclude/asm-mips/mach-tx49xx
  load-$(CONFIG_TOSHIBA_RBTX4938) += 0xffffffff80100000
  
  # temporary until string.h is fixed
  cflags-y += -ffreestanding
  
---- a/include/asm-mips/bootinfo.h
-+++ b/include/asm-mips/bootinfo.h
-@@ -79,6 +79,15 @@
- #define  MACH_LASAT_200               1       /* Masquerade PRO/SP200 */
- /*
-+ * Valid machtype for Atheros AR71xx based boards
-+ */
-+#define MACH_AR71XX_GENERIC   0
-+#define MACH_AR71XX_WP543     1       /* Compex WP543 */
-+#define MACH_AR71XX_RB_411    2       /* MikroTik RouterBOARD 411 */
-+#define MACH_AR71XX_RB_433    3       /* MikroTik RouterBOARD 433/433AH */
-+#define MACH_AR71XX_RB_450    4       /* MikroTik RouterBOARD 450 */
-+
-+/*
-  * Valid machtype for group NEC EMMA2RH
-  */
- #define  MACH_NEC_MARKEINS    0       /* NEC EMMA2RH Mark-eins        */
 --- a/arch/mips/Kconfig
 +++ b/arch/mips/Kconfig
-@@ -21,6 +21,24 @@
+@@ -21,6 +21,24 @@ choice
  config MACH_ALCHEMY
        bool "Alchemy processor based machines"
  
  config BASLER_EXCITE
        bool "Basler eXcite smart camera"
        select CEVT_R4K
+@@ -687,6 +705,7 @@ config WR_PPMC
+ endchoice
++source "arch/mips/ar71xx/Kconfig"
+ source "arch/mips/au1000/Kconfig"
+ source "arch/mips/basler/excite/Kconfig"
+ source "arch/mips/jazz/Kconfig"