ar71xx: update image generation and trx header parsing for the WRT160NL
[openwrt.git] / target / linux / ar71xx / Makefile
index 893742600762f95d709969f8df279230fc1864a3..74f409478e63c4170e369d5f2f3e57c3c9f49798 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2008-2009 OpenWrt.org
+# Copyright (C) 2008-2010 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,17 +8,20 @@ include $(TOPDIR)/rules.mk
 
 ARCH:=mips
 BOARD:=ar71xx
-BOARDNAME:=Atheros AR71xx/AR913x
-FEATURES:=squashfs tgz
+BOARDNAME:=Atheros AR71xx/AR7240/AR913x
+FEATURES:=squashfs jffs2 tgz
+CFLAGS:=-Os -pipe -mips32r2 -mtune=mips32r2 -funit-at-a-time
 
-LINUX_VERSION:=2.6.28.7
+LINUX_VERSION:=2.6.32.10
 
 include $(INCLUDE_DIR)/target.mk
 
-DEFAULT_PACKAGES += hostapd-mini kmod-madwifi kmod-gpio-leds
+DEFAULT_PACKAGES += \
+       kmod-leds-gpio kmod-input-core kmod-input-polldev \
+       kmod-input-gpio-buttons kmod-button-hotplug swconfig
 
 define Target/Description
-       Build firmware images for Atheros AR71xx/AR913x based boards
+       Build firmware images for Atheros AR71xx/AR913x based boards.
 endef
 
 $(eval $(call BuildTarget))