ar71xx: drivers/rb4xx_nand: remove C++ comment usage
[openwrt.git] / target / linux / ar71xx / Makefile
index 5948e825c857a65626a294e959eef8cd3df04b28..38fa8ff7df05ec70aa87167ab2ae533e1c459a0a 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2008-2009 OpenWrt.org
+# Copyright (C) 2008-2010 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,17 +8,18 @@ include $(TOPDIR)/rules.mk
 
 ARCH:=mips
 BOARD:=ar71xx
-BOARDNAME:=Atheros AR71xx/AR913x
-FEATURES:=squashfs jffs2 tgz
+BOARDNAME:=Atheros AR71xx/AR7240/AR913x
+FEATURES:=squashfs jffs2 targz
 CFLAGS:=-Os -pipe -mips32r2 -mtune=mips32r2 -funit-at-a-time
+SUBTARGETS:=generic nand
 
-LINUX_VERSION:=2.6.28.10
+LINUX_VERSION:=2.6.32.25
 
 include $(INCLUDE_DIR)/target.mk
 
 DEFAULT_PACKAGES += \
-       kmod-gpio-leds kmod-input-core kmod-input-polldev \
-       kmod-input-gpio-buttons kmod-button-hotplug
+       kmod-leds-gpio kmod-input-core kmod-input-polldev \
+       kmod-input-gpio-buttons kmod-button-hotplug swconfig
 
 define Target/Description
        Build firmware images for Atheros AR71xx/AR913x based boards.