make target/linux/* directories self-contained, use the selected kernel version for...
[openwrt.git] / target / linux / ar7-2.4 / Makefile
index 92e49d2020f6c257eb8dc5e8405815e1afca7d2b..f3d55da1918542429a5fa62ffa36bc6cd23fa2e6 100644 (file)
@@ -6,17 +6,18 @@
 #
 include $(TOPDIR)/rules.mk
 
+ARCH:=mipsel
+BOARD:=ar7
+BOARDNAME:=TI AR7
+FEATURES:=atm squashfs jffs2
+
+define Target/Description
+       Build firmware images for TI AR7 based routers (w.g. Linksys WAG54G v2)
+endef
+
 LINUX_VERSION:=2.4.32
 LINUX_RELEASE:=1
 LINUX_KERNEL_MD5SUM:=38f4d0830e95a20f4bfed17622d5557c
 
-include ./config
-include $(INCLUDE_DIR)/kernel.mk
 include $(INCLUDE_DIR)/kernel-build.mk
-
-$(LINUX_DIR)/.patched: $(LINUX_DIR)/.unpacked
-       [ -d ../generic-$(KERNEL)/patches ] && $(PATCH) $(LINUX_DIR) ../generic-$(KERNEL)/patches 
-       [ -d ./patches ] && $(PATCH) $(LINUX_DIR) ./patches
-       @$(CP) config $(LINUX_DIR)/.config
-       touch $@
-
+$(eval $(call BuildKernel))