ar7: add eva image generation (thanks Axel Gembe)
[openwrt.git] / target / linux / ar7 / image / Makefile
index 27af16553397282338b2a5a1973f69754bb3dd33..702c7aad2dfbcd30decad179400443bc14183fc7 100644 (file)
@@ -7,20 +7,22 @@
 include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/image.mk
 
-DROP_SECTIONS := .reginfo .mdebug .comment .note .pdr .options .MIPS.options
-OBJCOPY_SREC := $(TARGET_CROSS)objcopy -S -O srec $(addprefix --remove-section=,$(DROP_SECTIONS))
+DROP_SECTIONS:=.reginfo .mdebug .comment .note .pdr .options .MIPS.options
+OBJCOPY_SREC:=$(TARGET_CROSS)objcopy -S -O srec $(addprefix --remove-section=,$(DROP_SECTIONS))
 
-LOADADDR := 0x94600000
-KERNEL_ENTRY := 0x94100000
-RAMSTART := 0x94000000
-RAMSIZE := 0x00100000
+LOADADDR:=0x94600000
+KERNEL_ENTRY:=0x94100000
+RAMSTART:=0x94000000
+RAMSIZE:=0x00100000
+
+EVA_LOADADDR := 0x94100000
 
 LOADER_MAKEOPTS= \
-               KDIR=$(KDIR) \
-               LOADADDR=$(LOADADDR) \
-               KERNEL_ENTRY=$(KERNEL_ENTRY) \
-               RAMSTART=$(RAMSTART) \
-               RAMSIZE=$(RAMSIZE)
+       KDIR=$(KDIR) \
+       LOADADDR=$(LOADADDR) \
+       KERNEL_ENTRY=$(KERNEL_ENTRY) \
+       RAMSTART=$(RAMSTART) \
+       RAMSIZE=$(RAMSIZE)
 
 CFLAGS := -D__KERNEL__ -Wall -Wstrict-prototypes -Wno-trigraphs -Os \
        -fno-strict-aliasing -fno-common -fomit-frame-pointer -G 0 -mno-abicalls -fno-pic \
@@ -62,6 +64,12 @@ endef
 #      rm -f "$(KDIR)/dgfw.tmp"
 #endef
 
+define Image/Build/EVA
+       $(STAGING_DIR_HOST)/bin/lzma2eva $(KERNEL_ENTRY) $(KERNEL_ENTRY) $(BIN_DIR)/openwrt-$(2)-$(KERNEL)-$(1).bin
+       cat $(KDIR)/root.$(1) >> $(BIN_DIR)/openwrt-$(2)-$(KERNEL)-$(1).bin
+       $(call prepare_generic_squashfs,$(BIN_DIR)/openwrt-$(2)-$(KERNEL)-$(1).bin)
+endef
+
 define Image/Build
        dd if=$(KDIR)/loader.bin $(call align/$(1)) > $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(1).bin
        cat $(KDIR)/root.$(1) >> $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(1).bin
@@ -76,6 +84,7 @@ define Image/Build
        $(call Image/Build/CyberTAN,$(1),WA7B,WA7B -b,$(1))
 #      $(call Image/Build/sErCoMm,$(1),dg834,$(1))
 #      $(call Image/Build/sErCoMm,$(1),jdr454wb,$(1))
+       $(call Image/Build/EVA,$(1),EVA)
 endef
 
 $(eval $(call BuildImage))