ar71xx: image: improve the rootfs_align macro
[openwrt.git] / target / linux / amazon / Makefile
index 1967d52f42a2febe58017707279cb820b754cccd..d2d4e8d6736b843c9d0e7147bb755792c221e476 100644 (file)
@@ -9,17 +9,19 @@ include $(TOPDIR)/rules.mk
 ARCH:=mips
 BOARD:=amazon
 BOARDNAME:=Infineon Amazon
-FEATURES:=squashfs jffs2 broken
+FEATURES:=squashfs broken
+LINUX_VERSION:=3.3.8
+
+include $(INCLUDE_DIR)/target.mk
 
 define Target/Description
        Build firmware images for Infineon Amazon boards
 endef
 
-KERNELNAME:="uImage"
-
-include $(INCLUDE_DIR)/kernel-build.mk
-
-# include the profiles
--include profiles/*.mk
+define Kernel/Prepare
+       $(call Kernel/Prepare/Default)
+       mkdir -p $(LINUX_DIR)/arch/mips/include/asm/amazon
+       $(CP) $(LINUX_DIR)/include/asm-mips/amazon/*.h $(LINUX_DIR)/arch/mips/include/asm/amazon
+endef
 
-$(eval $(call BuildKernel))
+$(eval $(call BuildTarget))