[kernel] update to 2.6.27.15
[openwrt.git] / target / linux / adm5120 / patches-2.6.26 / 120-rb153_cf_driver.patch
index 57db596b5dd5d29be4ca1af668fe1c8ad975a5d2..e1001818491ef9e976dd0b29304b9b9d0bafdfd9 100644 (file)
@@ -1,6 +1,6 @@
 --- a/drivers/ata/Makefile
 +++ b/drivers/ata/Makefile
-@@ -72,6 +72,7 @@
+@@ -72,6 +72,7 @@ obj-$(CONFIG_PATA_BF54X)     += pata_bf54x.o
  obj-$(CONFIG_PATA_PLATFORM)   += pata_platform.o
  obj-$(CONFIG_PATA_OF_PLATFORM)        += pata_of_platform.o
  obj-$(CONFIG_PATA_ICSIDE)     += pata_icside.o
  # Should be last but one libata driver
 --- a/drivers/ata/Kconfig
 +++ b/drivers/ata/Kconfig
-@@ -566,6 +566,15 @@
+@@ -566,6 +566,15 @@ config PATA_RADISYS
  
          If unsure, say N.
  
 +config PATA_RB153_CF
 +      tristate "RouterBOARD 153 Compact Flash support"
-+      depends on MIPS_ADM5120
++      depends on ADM5120_MACH_RB_153
 +      help
 +        This option enables support for a Compact Flash connected on
 +        the RouterBOARD 153.