[ar71xx] experimental support for the Planex MZK-W04NU board
[openwrt.git] / target / linux / adm5120 / patches-2.6.26 / 003-adm5120_switch.patch
index b732b013ccf0b643c7c300dcf488012cf96147aa..ac0c5e30599bee6089dec87fe4cea24e9aba1e17 100644 (file)
@@ -1,23 +1,23 @@
 --- a/drivers/net/Kconfig
 +++ b/drivers/net/Kconfig
-@@ -613,6 +613,10 @@
+@@ -613,6 +613,10 @@ config MIPS_AU1X00_ENET
          If you have an Alchemy Semi AU1X00 based system
          say Y.  Otherwise, say N.
  
-+config MIPS_ADM5120_ENET
-+      tristate "MIPS ADM5120 Ethernet switch support"
-+      depends on MIPS_ADM5120
++config ADM5120_ENET
++      tristate "ADM5120 Ethernet switch support"
++      depends on ADM5120
 +
  config SGI_IOC3_ETH
        bool "SGI IOC3 Ethernet"
        depends on PCI && SGI_IP27
 --- a/drivers/net/Makefile
 +++ b/drivers/net/Makefile
-@@ -186,6 +186,7 @@
+@@ -186,6 +186,7 @@ obj-$(CONFIG_SC92031) += sc92031.o
  # This is also a 82596 and should probably be merged
  obj-$(CONFIG_LP486E) += lp486e.o
  
-+obj-$(CONFIG_MIPS_ADM5120_ENET) += adm5120sw.o
++obj-$(CONFIG_ADM5120_ENET) += adm5120sw.o
  obj-$(CONFIG_ETH16I) += eth16i.o
  obj-$(CONFIG_ZORRO8390) += zorro8390.o
  obj-$(CONFIG_HPLANCE) += hplance.o 7990.o