[adm5120] fix compiler warning
[openwrt.git] / target / linux / adm5120 / patches-2.6.25 / 001-adm5120.patch
index 5fe25a562d99fc70b7e1d76ac1bf39eb6bb057b3..84d0a8d2fc1c8a185b33d09b458f2583882c09e6 100644 (file)
@@ -1,8 +1,6 @@
-Index: linux-2.6.25/arch/mips/Kconfig
-===================================================================
---- linux-2.6.25.orig/arch/mips/Kconfig
-+++ linux-2.6.25/arch/mips/Kconfig
-@@ -18,6 +18,20 @@ choice
+--- a/arch/mips/Kconfig
++++ b/arch/mips/Kconfig
+@@ -18,6 +18,20 @@
        prompt "System type"
        default SGI_IP22
  
@@ -23,7 +21,7 @@ Index: linux-2.6.25/arch/mips/Kconfig
  config MACH_ALCHEMY
        bool "Alchemy processor based machines"
  
-@@ -683,6 +697,7 @@ config WR_PPMC
+@@ -683,6 +697,7 @@
  
  endchoice
  
@@ -31,11 +29,9 @@ Index: linux-2.6.25/arch/mips/Kconfig
  source "arch/mips/au1000/Kconfig"
  source "arch/mips/basler/excite/Kconfig"
  source "arch/mips/jazz/Kconfig"
-Index: linux-2.6.25/arch/mips/Makefile
-===================================================================
---- linux-2.6.25.orig/arch/mips/Makefile
-+++ linux-2.6.25/arch/mips/Makefile
-@@ -174,6 +174,16 @@ cflags-$(CONFIG_MACH_JAZZ)        += -Iinclude/
+--- a/arch/mips/Makefile
++++ b/arch/mips/Makefile
+@@ -174,6 +174,16 @@
  load-$(CONFIG_MACH_JAZZ)      += 0xffffffff80080000
  
  #
@@ -52,10 +48,8 @@ Index: linux-2.6.25/arch/mips/Makefile
  # Common Alchemy Au1x00 stuff
  #
  core-$(CONFIG_SOC_AU1X00)     += arch/mips/au1000/common/
-Index: linux-2.6.25/include/asm-mips/bootinfo.h
-===================================================================
---- linux-2.6.25.orig/include/asm-mips/bootinfo.h
-+++ linux-2.6.25/include/asm-mips/bootinfo.h
+--- a/include/asm-mips/bootinfo.h
++++ b/include/asm-mips/bootinfo.h
 @@ -94,6 +94,58 @@
  #define MACH_MSP7120_FPGA       5     /* PMC-Sierra MSP7120 Emulation */
  #define MACH_MSP_OTHER        255     /* PMC-Sierra unknown board type */