ixp4xx: add support for linux 3.10
[openwrt.git] / target / linux / adm5120 / image / router_le.mk
index 96ad2210620b4c827cd5ec224160554604dc6c10..6df6dcd8cc10f2880ecaf0db8f56d4ed33491c74 100644 (file)
@@ -209,6 +209,14 @@ define Image/Build/Template/Infineon/Initramfs
        $(call Image/Build/LZMAKernel/Admboot,$(1),gz)
 endef
 
+#
+# Generic EB-214A
+#
+define Image/Build/Template/Edimax/Initramfs
+       $(call Image/Build/LZMAKernel/Admboot,eb-214a,bin)
+endef
+
+
 #
 # Mikrotik RouterBOARD 1xx
 #
@@ -381,6 +389,7 @@ define Image/Build/Profile/Generic
        $(call Image/Build/Profile/BR6104KP,$(1))
        $(call Image/Build/Profile/BR6104WG,$(1))
        $(call Image/Build/Profile/BR6114WG,$(1))
+       $(call Image/Build/Profile/EB214A,$(1))
        # Infineon
        $(call Image/Build/Profile/EASY83000,$(1))
        $(call Image/Build/Profile/EASY5120RT,$(1))
@@ -390,23 +399,3 @@ define Image/Build/Profile/Generic
 
        $(call Image/Build/Experimental,$(1))
 endef
-
-ifeq ($(PROFILE),RouterBoard)
-  define Image/cmdline/yaffs2
-       root=/dev/mtdblock3 rootfstype=yaffs2
-  endef
-
-  define Image/BuildKernel/RouterBoard
-       $(CP) $(KDIR)/vmlinux.elf $(call imgname,kernel,rb1xx)
-       $(STAGING_DIR_HOST)/bin/patch-cmdline $(call imgname,kernel,rb1xx) \
-               '$(strip $(call Image/cmdline/yaffs2))'
-  endef
-
-  ifneq ($(CONFIG_TARGET_ROOTFS_INITRAMFS),y)
-    define Image/BuildKernel
-       $(call Image/BuildKernel/RouterBoard)
-    endef
-  endif
-
-endif
-