ar7: switch to 3.9
[openwrt.git] / target / linux / Makefile
index bab26845a15aae8e7b059af587f15ca386d1cf59..f7bbdffbf831654ca8617277e5fd7aeb8959f416 100644 (file)
@@ -1,18 +1,13 @@
+# 
+# Copyright (C) 2006-2007 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
 include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/target.mk
 
-source:
-       $(MAKE) -C $(BOARD)-$(KERNEL) source
+export TARGET_BUILD=1
 
-prepare:
-       rm -f $(TOPDIR)/.kernel.mk
-       $(MAKE) -C $(BOARD)-$(KERNEL) prepare
-
-compile:
-       $(MAKE) -C $(BOARD)-$(KERNEL) compile
-
-install:
-       $(MAKE) -C $(BOARD)-$(KERNEL) install
-       
-clean:
-       $(MAKE) -C $(BOARD)-$(KERNEL) clean
+prereq clean download prepare compile install menuconfig nconfig oldconfig update refresh: FORCE
+       @+$(NO_TRACE_MAKE) -C $(BOARD) $@