[package] firewall: don't setup nat reflection if negations are used
[openwrt.git] / package / wprobe / Makefile
index ab34f50d6b9df0157826f210ae246654c67fc3c7..65b85c235f335c8a5d27b6ab2e9d531436f56410 100644 (file)
@@ -24,7 +24,7 @@ include $(INCLUDE_DIR)/package.mk
 # wprobe-lib.c:149: error: 'packed' attribute ignored for field of type 'struct <anonymous>'
 
 define Package/wprobe/Default
-  DEPENDS:=@LINUX_2_6 @(!(TARGET_ps3||TARGET_pxcab||cris)||BROKEN)
+  DEPENDS:=@(!(TARGET_ps3||TARGET_pxcab||cris)||BROKEN)
 endef
 
 define KernelPackage/wprobe
@@ -33,7 +33,7 @@ $(call Package/wprobe/Default)
   TITLE:=Wireless driver probe infrastructure
   MAINTAINER:=Felix Fietkau <nbd@openwrt.org>
   FILES:= \
-       $(PKG_BUILD_DIR)/kernel/wprobe.$(LINUX_KMOD_SUFFIX)
+       $(PKG_BUILD_DIR)/kernel/wprobe.ko
   AUTOLOAD:=$(call AutoLoad,01,wprobe)
 endef