oops. accidentally committed the wrong patch version
[openwrt.git] / package / wpa_supplicant / Makefile
index a745313dac2d1954dacdf7e67300f4582a6605a4..361a486318bfbeff5a15305ea01f9f70f88784b2 100644 (file)
@@ -1,5 +1,5 @@
-# 
-# Copyright (C) 2006 OpenWrt.org
+#
+# Copyright (C) 2008 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,9 +9,9 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=wpa_supplicant
-PKG_VERSION:=0.5.7
+PKG_VERSION:=0.5.10
 PKG_RELEASE:=1
-PKG_MD5SUM:=bd2436392ad3c6d2513da701a12f2d27
+PKG_MD5SUM:=9e7b99da67c47d81121368c6d580d069
 
 PKG_SOURCE_URL:=http://hostap.epitest.fi/releases
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
@@ -48,6 +48,7 @@ endef
 define Build/Compile
        rm -rf $(PKG_INSTALL_DIR)
        mkdir -p $(PKG_INSTALL_DIR)
+       CFLAGS="$(TARGET_CFLAGS)" \
        $(MAKE) -C $(PKG_BUILD_DIR) \
                CC="$(TARGET_CC)" \
                KERNEL=$(LINUX_DIR) \