move package description to a separate definition, remove it when DESCRIPTION=TITLE
[openwrt.git] / package / wlcompat / Makefile
index 894938e96e76eb8ac4cd03b6f9a36ab8f6d9da0c..482ec4a2d276d7b6f6af52d235a91cdd02c76926 100644 (file)
@@ -10,31 +10,41 @@ include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/kernel.mk
 
 PKG_NAME:=kmod-wlcompat
-PKG_RELEASE:=4
-
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)
+PKG_RELEASE:=6
 
 include $(INCLUDE_DIR)/package.mk
 
-define Package/kmod-wlcompat
-SECTION:=drivers
-CATEGORY:=Drivers
-DEPENDS:=kmod-brcm-wl
-DEFAULT:=y
-TITLE:=Wrapper providing Wireless Extensions for Broadcom wl module
-DESCRIPTION:= \\\
-A wrapper module, that provides Wireless Extension support for the \\\
-proprietary Broadcom wl module.
-VERSION:=$(LINUX_VERSION)+$(BOARD)-$(PKG_RELEASE)
+define KernelPackage/wlcompat/Default
+  SUBMENU:=Proprietary BCM43xx WiFi driver
+  SUBMENUDEP:=@TARGET_BRCM_2_4
+  DEPENDS:=@TARGET_BRCM_2_4 @PACKAGE_kmod-brcm-wl||PACKAGE_kmod-brcm-wl-mimo +wireless-tools
+  TITLE:=Broadcom wl wrapper module
+endef
+
+define KernelPackage/wlcompat/Default/description
+ This package contains a wrapper module, that provides Wireless Extension 
+ support for the proprietary Broadcom wl module.
+endef
+
+define KernelPackage/wlcompat
+$(call KernelPackage/wlcompat/Default)
+  FILES:=$(PKG_BUILD_DIR)/wlcompat.o
+  AUTOLOAD:=$(call AutoLoad,50,wlcompat)
+endef
+
+define KernelPackage/wlcompat/description
+$(call KernelPackage/wlcompat/Default/description)
 endef
 
-define Package/kmod-wlcompat-debug
-$(call Package/kmod-wlcompat)
-DEFAULT:=m
-TITLE:=Wrapper providing Wireless Extensions for Broadcom wl module (debug)
-DESCRIPTION:= \\\
-A wrapper module, that provides Wireless Extension support for the \\\
-proprietary Broadcom wl module.
+define KernelPackage/wlcompat-debug
+$(call KernelPackage/wlcompat/Default)
+  TITLE+= (debug)
+  FILES:=$(PKG_BUILD_DIR)/wlcompat-debug.o
+endef
+
+define KernelPackage/wlcompat-debug/description
+$(call KernelPackage/wlcompat/Default/description)
+ This is a debugging version.
 endef
 
 define Build/Prepare
@@ -58,17 +68,5 @@ define Build/Compile
                modules
 endef
 
-define Package/kmod-wlcompat/install
-       install -d -m0755 $(1)/etc/modules.d
-       echo "wlcompat" > $(1)/etc/modules.d/30-wlcompat
-       install -d -m0755 $(1)/lib/modules/$(LINUX_VERSION)
-       $(CP) $(PKG_BUILD_DIR)/wlcompat.o $(1)/lib/modules/$(LINUX_VERSION)/
-endef
-
-define Package/kmod-wlcompat-debug/install
-       install -d -m0755 $(1)/lib/modules/$(LINUX_VERSION)
-       $(CP) $(PKG_BUILD_DIR)/wlcompat-debug.o $(1)/lib/modules/$(LINUX_VERSION)/
-endef
-
-$(eval $(call BuildPackage,kmod-wlcompat))
-$(eval $(call BuildPackage,kmod-wlcompat-debug))
+$(eval $(call KernelPackage,wlcompat))
+$(eval $(call KernelPackage,wlcompat-debug))