add tpc change from #1949
[openwrt.git] / package / util-linux / Makefile
index 5fc819bcfffb8d12b6684e5f5662b2c4d1513f9e..f624e92ccc95ead3f01c60563f7f5d65c5a81b8b 100644 (file)
@@ -10,7 +10,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=util-linux
 PKG_VERSION:=2.12r
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=ftp://ftp.kernel.org/pub/linux/utils/$(PKG_NAME)/ \
@@ -18,10 +18,6 @@ PKG_SOURCE_URL:=ftp://ftp.kernel.org/pub/linux/utils/$(PKG_NAME)/ \
        ftp://ftp.de.kernel.org/pub/linux/utils/$(PKG_NAME)/ \
        http://ftp.de.kernel.org/pub/linux/utils/$(PKG_NAME)/
 PKG_MD5SUM:=c261230b27fc0fbcc287c76884caf2d3
-PKG_CAT:=zcat
-
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
-PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -35,7 +31,16 @@ define Package/fdisk
   $(call Package/util-linux/Default)
   TITLE:=Partition table manipulation utility
   DESCRIPTION:=\
-       This package contains an utility for managing disk partition tables.
+       This package contains a utility for managing disk partition tables.
+  URL:=http://www.kernel.org/pub/linux/utils/util-linux/
+endef
+
+define Package/cfdisk
+  $(call Package/util-linux/Default)
+  TITLE:=Partition table manipulation utility
+  DEPENDS:=+libncurses
+  DESCRIPTION:=\
+       This package contains a utility for managing disk partition tables.
   URL:=http://www.kernel.org/pub/linux/utils/util-linux/
 endef
 
@@ -43,7 +48,7 @@ define Package/losetup
   $(call Package/util-linux/Default)
   TITLE:=Loopback devices setup and control utility
   DESCRIPTION:=\
-       This package contains an utility for managing loopback devices.
+       This package contains a utility for managing loopback devices.
 endef
 
 define Package/swap-utils
@@ -56,6 +61,13 @@ define Package/swap-utils
        - swapoff
 endef
 
+define Package/hwclock
+  $(call Package/util-linux/Default)
+  TITLE:=Utilities for managing the hardware clock
+  DESCRIPTION:=\
+        This package contains a utility for managing the hardware clock
+endef
+
 TARGET_CFLAGS += -I$(PKG_BUILD_DIR)/lib
 define Build/Compile
        $(call Build/Compile/Default, \
@@ -79,6 +91,10 @@ define Package/fdisk/install
        $(call Package/Template,sbin/fdisk,$(1)/usr/sbin)
 endef
 
+define Package/cfdisk/install
+       $(call Package/Template,sbin/cfdisk,$(1)/usr/sbin)
+endef
+
 define Package/losetup/install
        $(call Package/Template,sbin/losetup,$(1)/usr/sbin)
 endef
@@ -89,6 +105,12 @@ define Package/swap-utils/install
        $(call Package/Template,sbin/swapoff,$(1)/usr/sbin)
 endef
 
+define Package/hwclock/install
+       $(call Package/Template,sbin/hwclock,$(1)/usr/sbin)
+endef
+
 $(eval $(call BuildPackage,fdisk))
+$(eval $(call BuildPackage,cfdisk))
 $(eval $(call BuildPackage,losetup))
 $(eval $(call BuildPackage,swap-utils))
+$(eval $(call BuildPackage,hwclock))