lua: add reference counting for strings - this will need A LOT of testing, but it...
[openwrt.git] / package / uboot-ifxmips / Makefile
index 10e9080e8b1752e234ab216d3f8b83c0b5a66e7e..ade82bf7b99376106c328ebccc865a98b7db0480 100644 (file)
@@ -16,7 +16,6 @@ PKG_BUILD_DIR:=$(KERNEL_BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=ftp://ftp.denx.de/pub/u-boot
 PKG_MD5SUM:=579707c8ecbf1ab4127285d2aac2a9ee
-PKG_CAT:=bzcat
 PKG_TARGETS:=bin
 
 include $(INCLUDE_DIR)/package.mk
@@ -51,18 +50,25 @@ define Build/Configure
 endef
 
 define Build/Compile
-       $(MAKE) -s -C $(PKG_BUILD_DIR) \
+       $(MAKE) -C $(PKG_BUILD_DIR) \
                $(UBOOT_MAKE_OPTS) \
+               OWRT_FLAGS="-DTEXT_BASE=0xa0400000" \
                ifx_all
-       if [ `stat -c%s $(PKG_BUILD_DIR)/u-boot.ifx` -gt 65536 ] ;\
-       then \
-               echo "u-boot.ifx file has exceeded 64MB in size."; exit 1; \
-       fi
+       $(CP) $(PKG_BUILD_DIR)/u-boot.srec $(PKG_BUILD_DIR)/asc.srec
+       $(PKG_BUILD_DIR)/gct \
+               $(PKG_BUILD_DIR)/danube_ref_ddr166.conf \
+               $(PKG_BUILD_DIR)/asc.srec \
+               $(PKG_BUILD_DIR)/u-boot.asc
+       $(MAKE) -C $(PKG_BUILD_DIR) \
+               $(UBOOT_MAKE_OPTS) \
+               OWRT_FLAGS="-DDANUBE_BOOT_FROM_EBU=1 -DTEXT_BASE=0xB0000000" \
+               clean ifx_all
 endef
 
 define Package/uboot-ifxmips/install
        mkdir -p $(1)
        dd if=$(PKG_BUILD_DIR)/u-boot.ifx of=$(1)/u-boot.ifx bs=64k conv=sync
+       $(CP) $(PKG_BUILD_DIR)/u-boot.asc $(1)
 endef
 
 $(eval $(call BuildPackage,uboot-ifxmips))