copy uclibc++ package from whiterussian to head
[openwrt.git] / package / rules.mk
index 53b868d1aca14cb391f4a15c40cb43c77079133d..a95c4e421b025983941696728cfef93e71bd2698 100644 (file)
@@ -13,8 +13,11 @@ ifeq ($(BR2_PACKAGE_$(1)),y)
 install: $$(INFO_$(1))
 endif
 
+IDEPEND_$(1):=$$(strip $(5))
+
 $$(IDIR_$(1))/CONTROL/control: $(PKG_BUILD_DIR)/.prepared
        $(SCRIPT_DIR)/make-ipkg-dir.sh $$(IDIR_$(1)) ./ipkg/$(2).control $(3) $(4)
+       if [ "$$(IDEPEND_$(1))" != "" ]; then echo "Depends: $$(IDEPEND_$(1))" >> $$(IDIR_$(1))/CONTROL/control; fi
        for file in conffiles preinst postinst prerm postrm; do \
                [ -f ./ipkg/$(2).$$$$file ] && cp ./ipkg/$(2).$$$$file $$(IDIR_$(1))/CONTROL/$$$$file || true; \
        done
@@ -27,12 +30,6 @@ $$(INFO_$(1)): $$(IPKG_$(1))
 $(2)-clean:
        rm -f $$(IPKG_$(1))
 clean: $(2)-clean
-mostlyclean:
-rebuild: mostlyclean
-       if [ -f $(PKG_BUILD_DIR)/.built ]; then \
-               $(MAKE) clean; \
-       fi
-       $(MAKE) compile
 endef
 
 ifneq ($(strip $(PKG_SOURCE)),)
@@ -57,6 +54,13 @@ source: $(DL_DIR)/$(PKG_SOURCE)
 prepare: $(PKG_BUILD_DIR)/.prepared
 compile:
 install:
+mostlyclean:
+rebuild:
+       -$(MAKE) mostlyclean
+       if [ -f $(PKG_BUILD_DIR)/.built ]; then \
+               $(MAKE) clean; \
+       fi
+       $(MAKE) compile
 
 $(PKG_BUILD_DIR)/.configured: $(PKG_BUILD_DIR)/.prepared
 $(PKG_BUILD_DIR)/.built: $(PKG_BUILD_DIR)/.configured
@@ -64,7 +68,6 @@ $(PKG_BUILD_DIR)/.built: $(PKG_BUILD_DIR)/.configured
 $(PACKAGE_DIR):
        mkdir -p $@
 
-
 clean: 
        rm -rf $(PKG_BUILD_DIR)