change defaults to check for configure script (avoids defining a null rule otherwise)
[openwrt.git] / package / rules.mk
index 5316debca343d73a8d20b12ddfbcb88a420695b4..3f79b9f6be1fe08834413a883bf311990e79fdc5 100644 (file)
@@ -81,13 +81,13 @@ IPKG_$(1):=$(PACKAGE_DIR)/$(1)_$(VERSION)_$(PKGARCH).ipk
 IDIR_$(1):=$(PKG_BUILD_DIR)/ipkg/$(1)
 INFO_$(1):=$(IPKG_STATE_DIR)/info/$(1).list
 
-ifneq ($(PACKAGE_$(1)),)
+ifneq ($(CONFIG_PACKAGE_$(1)),)
 COMPILE_$(1):=1
 endif
 ifneq ($(DEVELOPER),)
 COMPILE_$(1):=1
 endif
-ifeq ($(PACKAGE_$(1)),y)
+ifeq ($(CONFIG_PACKAGE_$(1)),y)
 install-targets: $$(INFO_$(1))
 endif
 
@@ -117,9 +117,13 @@ DUMPINFO += \
        echo "Depends: $$(IDEPEND_$(1))"; \
        echo "Category: $(CATEGORY)"; \
        echo "Title: $(TITLE)"; \
-       echo "Description: $(DESCRIPTION)" | sed -e 's,\\,\n,g'; \
+       echo "Description: $(DESCRIPTION)" | sed -e 's,\\,\n,g';
+ifneq ($(URL),)
+DUMPINFO += \
        echo; \
-       echo "$(URL)"; \
+       echo "$(URL)";
+endif
+DUMPINFO += \
        echo "@@";
 
 
@@ -183,15 +187,40 @@ $(call Build/Prepare/Default)
 endef
 
 define Build/Configure/Default
-# TODO: add configurable default command
+       (cd $(PKG_BUILD_DIR); \
+       [ -x configure ] && \
+               $(TARGET_CONFIGURE_OPTS) \
+               CFLAGS="$(TARGET_CFLAGS)" \
+               ./configure \
+               --target=$(GNU_TARGET_NAME) \
+               --host=$(GNU_TARGET_NAME) \
+               --build=$(GNU_HOST_NAME) \
+               --prefix=/usr \
+               --exec-prefix=/usr \
+               --bindir=/usr/bin \
+               --sbindir=/usr/sbin \
+               --libexecdir=/usr/lib \
+               --sysconfdir=/etc \
+               --datadir=/usr/share \
+               --localstatedir=/var \
+               --mandir=/usr/man \
+               --infodir=/usr/info \
+               $(DISABLE_NLS) \
+               $(1); \
+       )
 endef
 
 define Build/Configure
-$(call Build/Configure/Default)
 endef
 
 define Build/Compile/Default
-# TODO: add configurable default command
+       $(MAKE) -C $(PKG_BUILD_DIR) \
+               CC=$(TARGET_CC) \
+               CROSS="$(TARGET_CROSS)" \
+               PREFIX="$$(IDIR_$(1))" \
+               EXTRA_CFLAGS="$(TARGET_CFLAGS)" \
+               ARCH="$(ARCH)" \
+               DESTDIR="$$(IDIR_$(1))"
 endef
 
 define Build/Compile