fix ppp compile on osx
[openwrt.git] / package / ppp / Makefile
index 680076857eb255c4c79985656b3e10545c88cf71..b5a317bd03efc25cb592492fc84a871f7f0a7bbc 100644 (file)
@@ -23,6 +23,7 @@ PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
 PKG_BUILDDEP:=libpcap linux-atm
 
 include $(INCLUDE_DIR)/package.mk
+include $(INCLUDE_DIR)/kernel.mk
 
 define Package/ppp/Default
   SECTION:=net
@@ -91,6 +92,14 @@ define Package/pppstats
        This package contains an utility to report PPP statistics.
 endef
 
+define Build/Configure
+$(call Build/Configure/Default,, \
+       UNAME_S="Linux" \
+       UNAME_R="$(LINUX_VERSION)" \
+       UNAME_M="$(ARCH)" \
+)
+endef
+
 define Build/Compile
        rm -rf $(PKG_INSTALL_DIR)
        mkdir -p $(PKG_INSTALL_DIR)/usr