enable pppoa for ar7
[openwrt.git] / package / ppp / Makefile
index 680076857eb255c4c79985656b3e10545c88cf71..80c6f5afe8fdfbb83832d0c7381739a950bee945 100644 (file)
@@ -23,6 +23,7 @@ PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
 PKG_BUILDDEP:=libpcap linux-atm
 
 include $(INCLUDE_DIR)/package.mk
+include $(INCLUDE_DIR)/kernel.mk
 
 define Package/ppp/Default
   SECTION:=net
@@ -43,6 +44,7 @@ endef
 define Package/ppp-mod-pppoa
   $(call Package/ppp/Default)
   DEPENDS:=ppp +linux-atm +kmod-pppoa
+  DEFAULT:=y if LINUX_2_4_AR7
   TITLE:=PPPoA plugin
   DESCRIPTION:=\
        This package contains a PPPoA (PPP over ATM) plugin for ppp.
@@ -91,6 +93,14 @@ define Package/pppstats
        This package contains an utility to report PPP statistics.
 endef
 
+define Build/Configure
+$(call Build/Configure/Default,, \
+       UNAME_S="Linux" \
+       UNAME_R="$(LINUX_VERSION)" \
+       UNAME_M="$(ARCH)" \
+)
+endef
+
 define Build/Compile
        rm -rf $(PKG_INSTALL_DIR)
        mkdir -p $(PKG_INSTALL_DIR)/usr