Remove autodection of hesiod since it will be enabled by default if present on host...
[openwrt.git] / package / openswan / Makefile
index a25f12d374b9a16dd21f3a307adaef76337b31a0..69787c0c80412abb78ca91da4c5f5c65807c4cee 100644 (file)
@@ -3,9 +3,9 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=openswan
-PKG_VERSION:=2.4.0
+PKG_VERSION:=2.4.5rc5
 PKG_RELEASE:=1
-PKG_MD5SUM:=6cbba783658eb62b87cbf4937f5e8464
+PKG_MD5SUM:=c2547f70b2d7c33deafb2b230305cef5
 
 PKG_SOURCE_URL:=http://www.openswan.org/download
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
@@ -18,6 +18,9 @@ $(eval $(call PKG_template,OPENSWAN,openswan,$(PKG_VERSION)-$(PKG_RELEASE),$(ARC
 
 FLAGS := $(TARGET_CFLAGS) -I$(PKG_BUILD_DIR)/linux/include -L$(STAGING_DIR)/usr/lib -I$(STAGING_DIR)/usr/include
 
+$(PKG_BUILD_DIR)/.configured:
+       touch $@
+
 $(PKG_BUILD_DIR)/.built:
        $(MAKE) -C $(PKG_BUILD_DIR) \
                $(TARGET_CONFIGURE_OPTS) \
@@ -29,6 +32,7 @@ $(PKG_BUILD_DIR)/.built:
                IPSECDIR="/usr/lib/ipsec" \
                INC_USRLOCAL="/usr" \
                programs
+       touch $@
 
 $(IPKG_OPENSWAN):
        $(MAKE) -C $(PKG_BUILD_DIR) \