openssl: use assembler version of aes on arm - nearly doubles aes encryption performance
[openwrt.git] / package / openssl / patches / 160-disable_doc_tests.patch
index 9706a0b2a82469a2f739b2f5f248e386ee1a6a69..e64a9193b3f6c367854b7dd62586a45b2ea991cc 100644 (file)
@@ -1,26 +1,25 @@
-Index: openssl-0.9.8e/Makefile
-===================================================================
---- openssl-0.9.8e.orig/Makefile       2007-06-04 13:23:31.995869784 +0200
-+++ openssl-0.9.8e/Makefile    2007-06-04 13:23:33.246679632 +0200
-@@ -106,7 +106,7 @@
- ZLIB_INCLUDE=
- LIBZLIB=
+diff -burN openssl-0.9.8k/Makefile openssl-0.9.8k.patched/Makefile
+--- openssl-0.9.8k/Makefile    2009-03-25 14:11:43.000000000 +0100
++++ openssl-0.9.8k.patched/Makefile    2009-03-26 15:28:35.483566078 +0100
+@@ -133,7 +133,7 @@
+ BASEADDR=0xFB00000
  
 -DIRS=   crypto ssl engines apps test tools
 +DIRS=   crypto ssl engines apps tools
  SHLIBDIRS= crypto ssl
  
  # dirs in crypto to build
-@@ -123,7 +123,7 @@
+@@ -150,7 +150,7 @@
  
  # tests to perform.  "alltests" is a special word indicating that all tests
  # should be performed.
 -TESTS = alltests
-+TESTS = 
++TESTS =
  
  MAKEFILE= Makefile
  
-@@ -135,7 +135,7 @@
+@@ -162,7 +162,7 @@
  
  TOP=    .
  ONEDIRS=out tmp
@@ -29,16 +28,16 @@ Index: openssl-0.9.8e/Makefile
  WDIRS=  windows
  LIBS=   libcrypto.a libssl.a
  SHARED_CRYPTO=libcrypto$(SHLIB_EXT)
-@@ -225,7 +225,7 @@
-       @[ -n "$(THIS)" ] && $(CLEARENV) && $(MAKE) $(THIS) -e $(BUILDENV)
+@@ -321,7 +321,7 @@
+       ../crypto/uid.o
  
  sub_all: build_all
 -build_all: build_libs build_apps build_tests build_tools
 +build_all: build_libs build_apps build_tools
  
- build_libs: build_crypto build_ssl build_engines
+ build_libs: build_crypto build_fips build_ssl build_shared build_engines
  
-@@ -475,7 +475,7 @@
+@@ -613,7 +613,7 @@
  dist_pem_h:
        (cd crypto/pem; $(MAKE) -e $(BUILDENV) pem.h; $(MAKE) clean)
  
@@ -47,11 +46,10 @@ Index: openssl-0.9.8e/Makefile
  
  install_sw:
        @$(PERL) $(TOP)/util/mkdir-p.pl $(INSTALL_PREFIX)$(INSTALLTOP)/bin \
-Index: openssl-0.9.8e/Makefile.org
-===================================================================
---- openssl-0.9.8e.orig/Makefile.org   2007-06-04 13:23:32.857738760 +0200
-+++ openssl-0.9.8e/Makefile.org        2007-06-04 13:23:33.246679632 +0200
-@@ -473,7 +473,7 @@
+diff -burN openssl-0.9.8k/Makefile.org openssl-0.9.8k.patched/Makefile.org
+--- openssl-0.9.8k/Makefile.org        2009-03-03 23:40:29.000000000 +0100
++++ openssl-0.9.8k.patched/Makefile.org        2009-03-26 15:29:05.243750064 +0100
+@@ -611,7 +611,7 @@
  dist_pem_h:
        (cd crypto/pem; $(MAKE) -e $(BUILDENV) pem.h; $(MAKE) clean)