libubox: update to latest version, fixes issues with using the library from C++ code
[openwrt.git] / package / openssl / patches / 160-disable_doc_tests.patch
index e64a9193b3f6c367854b7dd62586a45b2ea991cc..4ae35b1b6f42d3a974a1d1e8efdcdc4fedcea9c5 100644 (file)
@@ -1,16 +1,15 @@
-diff -burN openssl-0.9.8k/Makefile openssl-0.9.8k.patched/Makefile
---- openssl-0.9.8k/Makefile    2009-03-25 14:11:43.000000000 +0100
-+++ openssl-0.9.8k.patched/Makefile    2009-03-26 15:28:35.483566078 +0100
-@@ -133,7 +133,7 @@
- BASEADDR=0xFB00000
+--- a/Makefile
++++ b/Makefile
+@@ -111,7 +111,7 @@ LIBKRB5=
+ ZLIB_INCLUDE=
+ LIBZLIB=
  
 -DIRS=   crypto ssl engines apps test tools
 +DIRS=   crypto ssl engines apps tools
+ ENGDIRS= ccgost
  SHLIBDIRS= crypto ssl
  
- # dirs in crypto to build
-@@ -150,7 +150,7 @@
+@@ -129,7 +129,7 @@ SDIRS=  \
  
  # tests to perform.  "alltests" is a special word indicating that all tests
  # should be performed.
@@ -19,7 +18,7 @@ diff -burN openssl-0.9.8k/Makefile openssl-0.9.8k.patched/Makefile
  
  MAKEFILE= Makefile
  
-@@ -162,7 +162,7 @@
+@@ -143,7 +143,7 @@ SHELL=/bin/sh
  
  TOP=    .
  ONEDIRS=out tmp
@@ -28,16 +27,16 @@ diff -burN openssl-0.9.8k/Makefile openssl-0.9.8k.patched/Makefile
  WDIRS=  windows
  LIBS=   libcrypto.a libssl.a
  SHARED_CRYPTO=libcrypto$(SHLIB_EXT)
-@@ -321,7 +321,7 @@
-       ../crypto/uid.o
+@@ -239,7 +239,7 @@ reflect:
+       @[ -n "$(THIS)" ] && $(CLEARENV) && $(MAKE) $(THIS) -e $(BUILDENV)
  
  sub_all: build_all
 -build_all: build_libs build_apps build_tests build_tools
 +build_all: build_libs build_apps build_tools
  
- build_libs: build_crypto build_fips build_ssl build_shared build_engines
+ build_libs: build_crypto build_ssl build_engines
  
-@@ -613,7 +613,7 @@
+@@ -494,7 +494,7 @@ dist:
  dist_pem_h:
        (cd crypto/pem; $(MAKE) -e $(BUILDENV) pem.h; $(MAKE) clean)
  
@@ -46,10 +45,9 @@ diff -burN openssl-0.9.8k/Makefile openssl-0.9.8k.patched/Makefile
  
  install_sw:
        @$(PERL) $(TOP)/util/mkdir-p.pl $(INSTALL_PREFIX)$(INSTALLTOP)/bin \
-diff -burN openssl-0.9.8k/Makefile.org openssl-0.9.8k.patched/Makefile.org
---- openssl-0.9.8k/Makefile.org        2009-03-03 23:40:29.000000000 +0100
-+++ openssl-0.9.8k.patched/Makefile.org        2009-03-26 15:29:05.243750064 +0100
-@@ -611,7 +611,7 @@
+--- a/Makefile.org
++++ b/Makefile.org
+@@ -492,7 +492,7 @@ dist:
  dist_pem_h:
        (cd crypto/pem; $(MAKE) -e $(BUILDENV) pem.h; $(MAKE) clean)