libubox: update to latest version, fixes issues with using the library from C++ code
[openwrt.git] / package / openssl / patches / 160-disable_doc_tests.patch
index 27e203347552e745c36aabe011677c6445d29770..4ae35b1b6f42d3a974a1d1e8efdcdc4fedcea9c5 100644 (file)
@@ -1,25 +1,24 @@
-diff -urN openssl-0.9.8a/Makefile openssl-0.9.8a.new/Makefile
---- openssl-0.9.8a/Makefile    2005-10-11 12:21:48.000000000 +0200
-+++ openssl-0.9.8a.new/Makefile        2006-03-29 15:23:28.107586680 +0200
-@@ -102,7 +102,7 @@
- KRB5_INCLUDES=
- LIBKRB5=
+--- a/Makefile
++++ b/Makefile
+@@ -111,7 +111,7 @@ LIBKRB5=
+ ZLIB_INCLUDE=
+ LIBZLIB=
  
 -DIRS=   crypto ssl engines apps test tools
 +DIRS=   crypto ssl engines apps tools
+ ENGDIRS= ccgost
  SHLIBDIRS= crypto ssl
  
- # dirs in crypto to build
-@@ -119,7 +119,7 @@
+@@ -129,7 +129,7 @@ SDIRS=  \
  
  # tests to perform.  "alltests" is a special word indicating that all tests
  # should be performed.
 -TESTS = alltests
-+TESTS = 
++TESTS =
  
  MAKEFILE= Makefile
  
-@@ -131,7 +131,7 @@
+@@ -143,7 +143,7 @@ SHELL=/bin/sh
  
  TOP=    .
  ONEDIRS=out tmp
@@ -28,7 +27,7 @@ diff -urN openssl-0.9.8a/Makefile openssl-0.9.8a.new/Makefile
  WDIRS=  windows
  LIBS=   libcrypto.a libssl.a
  SHARED_CRYPTO=libcrypto$(SHLIB_EXT)
-@@ -204,7 +204,7 @@
+@@ -239,7 +239,7 @@ reflect:
        @[ -n "$(THIS)" ] && $(CLEARENV) && $(MAKE) $(THIS) -e $(BUILDENV)
  
  sub_all: build_all
@@ -37,7 +36,7 @@ diff -urN openssl-0.9.8a/Makefile openssl-0.9.8a.new/Makefile
  
  build_libs: build_crypto build_ssl build_engines
  
-@@ -454,7 +454,7 @@
+@@ -494,7 +494,7 @@ dist:
  dist_pem_h:
        (cd crypto/pem; $(MAKE) -e $(BUILDENV) pem.h; $(MAKE) clean)
  
@@ -46,10 +45,9 @@ diff -urN openssl-0.9.8a/Makefile openssl-0.9.8a.new/Makefile
  
  install_sw:
        @$(PERL) $(TOP)/util/mkdir-p.pl $(INSTALL_PREFIX)$(INSTALLTOP)/bin \
-diff -urN openssl-0.9.8b/Makefile.org openssl-0.9.8b.new/Makefile.org
---- openssl-0.9.8b/Makefile.org        2006-09-01 19:34:51.000000000 +0200
-+++ openssl-0.9.8b.new/Makefile.org    2006-09-01 19:36:38.000000000 +0200
-@@ -473,7 +473,7 @@
+--- a/Makefile.org
++++ b/Makefile.org
+@@ -492,7 +492,7 @@ dist:
  dist_pem_h:
        (cd crypto/pem; $(MAKE) -e $(BUILDENV) pem.h; $(MAKE) clean)