iptables: use -ffunction-sections, -fdata-sections and --gc-sections
[openwrt.git] / package / network / utils / iptables / Makefile
index 4140acb77d4e9ba6ab5b74222891c8fa37daca9f..a0ea7f7ce0c7c1ea998f9aa6e14c84145dca74cd 100644 (file)
@@ -10,7 +10,7 @@ include $(INCLUDE_DIR)/kernel.mk
 
 PKG_NAME:=iptables
 PKG_VERSION:=1.4.18
-PKG_RELEASE:=3
+PKG_RELEASE:=4
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=http://www.netfilter.org/projects/iptables/files \
@@ -301,7 +301,7 @@ endef
 define Package/ip6tables
 $(call Package/iptables/Default)
   DEPENDS:=@IPV6 +kmod-ip6tables +iptables
-  CATEGORY:=IPv6
+  CATEGORY:=Network
   TITLE:=IPv6 firewall administration tool
   MENU:=1
 endef
@@ -342,7 +342,11 @@ TARGET_CPPFLAGS := \
 
 TARGET_CFLAGS += \
        -I$(PKG_BUILD_DIR)/include \
-       -I$(LINUX_DIR)/user_headers/include
+       -I$(LINUX_DIR)/user_headers/include \
+       -ffunction-sections -fdata-sections
+
+TARGET_LDFLAGS += \
+       -Wl,--gc-sections
 
 CONFIGURE_ARGS += \
        --enable-shared \