oops, applied the ipkg patch with the wrong patchlevel
[openwrt.git] / package / madwifi / patches / 200-no_debug.patch
index cd733509392568d4e5a071f00ca5338fc93cb95d..a54b33d529db6510598a1c23ed63569df66b0eaa 100644 (file)
@@ -1,19 +1,72 @@
-diff -Nur madwifi-0.9.2.1/ath/if_ath.c madwifi-0.9.2.1-nodebug/ath/if_ath.c
---- madwifi-0.9.2.1/ath/if_ath.c       2006-07-08 08:47:19.000000000 +0200
-+++ madwifi-0.9.2.1-nodebug/ath/if_ath.c       2007-02-20 11:48:05.000000000 +0100
-@@ -72,7 +72,7 @@
- #include <net80211/if_llc.h>
- #endif
+Index: madwifi-dfs-r3053/ath/if_ath.c
+===================================================================
+--- madwifi-dfs-r3053.orig/ath/if_ath.c        2007-12-13 05:25:13.122373270 +0100
++++ madwifi-dfs-r3053/ath/if_ath.c     2007-12-13 05:25:13.342385808 +0100
+@@ -42,7 +42,7 @@
+  * This software is derived from work of Atsushi Onoe; his contribution
+  * is greatly appreciated.
+  */
 -#define       AR_DEBUG
 +#undef        AR_DEBUG
+ #include "if_ath_debug.h"
+ #include "opt_ah.h"
  
- #include "if_athrate.h"
- #include "net80211/if_athproto.h"
-diff -Nur madwifi-0.9.2.1/ath_rate/amrr/amrr.c madwifi-0.9.2.1-nodebug/ath_rate/amrr/amrr.c
---- madwifi-0.9.2.1/ath_rate/amrr/amrr.c       2006-07-04 12:23:35.000000000 +0200
-+++ madwifi-0.9.2.1-nodebug/ath_rate/amrr/amrr.c       2007-02-20 11:49:10.000000000 +0100
-@@ -67,7 +67,7 @@
+@@ -516,9 +516,11 @@
+       u_int8_t csz;
+       sc->devid = devid;
++#ifdef AR_DEBUG
+       ath_debug_global = (ath_debug & ATH_DEBUG_GLOBAL);
+       sc->sc_debug     = (ath_debug & ~ATH_DEBUG_GLOBAL);
+       DPRINTF(sc, ATH_DEBUG_ANY, "%s: devid 0x%x\n", __func__, devid);
++#endif
+       /*
+        * Cache line size is used to size and align various
+@@ -1280,12 +1282,14 @@
+               /* If no default VAP debug flags are passed, allow a few to
+                * transfer down from the driver to new VAPs so we can have load
+                * time debugging for VAPs too. */
++#ifdef AR_DEBUG
+               vap->iv_debug = 0 |
+                       ((sc->sc_debug & ATH_DEBUG_RATE) ? IEEE80211_MSG_XRATE  : 0) | 
+                       ((sc->sc_debug & ATH_DEBUG_XMIT) ? IEEE80211_MSG_OUTPUT : 0) | 
+                       ((sc->sc_debug & ATH_DEBUG_RECV) ? IEEE80211_MSG_INPUT  : 0) |
+                       0
+                       ;
++#endif
+       }
+       ic->ic_debug = (sc->sc_default_ieee80211_debug & IEEE80211_MSG_IC);
+@@ -10308,9 +10312,11 @@
+                               /* XXX validate? */
+                               sc->sc_ledpin = val;
+                               break;
++#ifdef AR_DEBUG
+                       case ATH_DEBUG:
+                               sc->sc_debug     = (val & ~ATH_DEBUG_GLOBAL);
+                               ath_debug_global = (val &  ATH_DEBUG_GLOBAL);
++#endif
+                               break;
+                       case ATH_TXANTENNA:
+                               /*
+@@ -10721,9 +10727,11 @@
+       }
+       /* initialize values */
++#ifdef AR_DEBUG
+       ath_debug_global = (ath_debug & ATH_DEBUG_GLOBAL);
+       sc->sc_debug     = (ath_debug & ~ATH_DEBUG_GLOBAL);
+       sc->sc_default_ieee80211_debug = ieee80211_debug;
++#endif
+       sc->sc_txantenna = 0;           /* default to auto-selection */
+       sc->sc_txintrperiod = ATH_TXQ_INTR_PERIOD;
+ }
+Index: madwifi-dfs-r3053/ath_rate/amrr/amrr.c
+===================================================================
+--- madwifi-dfs-r3053.orig/ath_rate/amrr/amrr.c        2007-12-13 05:25:10.422219395 +0100
++++ madwifi-dfs-r3053/ath_rate/amrr/amrr.c     2007-12-13 05:25:13.342385808 +0100
+@@ -70,7 +70,7 @@
  
  #include "amrr.h"
  
@@ -22,10 +75,24 @@ diff -Nur madwifi-0.9.2.1/ath_rate/amrr/amrr.c madwifi-0.9.2.1-nodebug/ath_rate/
  #ifdef AMRR_DEBUG
  #define       DPRINTF(sc, _fmt, ...) do {                                     \
        if (sc->sc_debug & 0x10)                                        \
-diff -Nur madwifi-0.9.2.1/ath_rate/onoe/onoe.c madwifi-0.9.2.1-nodebug/ath_rate/onoe/onoe.c
---- madwifi-0.9.2.1/ath_rate/onoe/onoe.c       2006-07-04 12:23:35.000000000 +0200
-+++ madwifi-0.9.2.1-nodebug/ath_rate/onoe/onoe.c       2007-02-20 11:48:51.000000000 +0100
-@@ -63,7 +63,7 @@
+Index: madwifi-dfs-r3053/ath_rate/minstrel/minstrel.c
+===================================================================
+--- madwifi-dfs-r3053.orig/ath_rate/minstrel/minstrel.c        2007-12-13 05:25:12.006309667 +0100
++++ madwifi-dfs-r3053/ath_rate/minstrel/minstrel.c     2007-12-13 05:25:13.350386263 +0100
+@@ -117,7 +117,7 @@
+ #include "minstrel.h"
+-#define       MINSTREL_DEBUG
++#undef        MINSTREL_DEBUG
+ #ifdef MINSTREL_DEBUG
+ enum {
+               ATH_DEBUG_RATE          = 0x00000010    /* rate control */
+Index: madwifi-dfs-r3053/ath_rate/onoe/onoe.c
+===================================================================
+--- madwifi-dfs-r3053.orig/ath_rate/onoe/onoe.c        2007-12-13 05:25:10.438220308 +0100
++++ madwifi-dfs-r3053/ath_rate/onoe/onoe.c     2007-12-13 05:25:13.354386489 +0100
+@@ -66,7 +66,7 @@
  
  #include "onoe.h"
  
@@ -34,10 +101,11 @@ diff -Nur madwifi-0.9.2.1/ath_rate/onoe/onoe.c madwifi-0.9.2.1-nodebug/ath_rate/
  #ifdef ONOE_DEBUG
  enum {
        ATH_DEBUG_RATE  = 0x00000010,   /* rate control */
-diff -Nur madwifi-0.9.2.1/ath_rate/sample/sample.c madwifi-0.9.2.1-nodebug/ath_rate/sample/sample.c
---- madwifi-0.9.2.1/ath_rate/sample/sample.c   2006-07-04 12:23:35.000000000 +0200
-+++ madwifi-0.9.2.1-nodebug/ath_rate/sample/sample.c   2007-02-20 11:48:31.000000000 +0100
-@@ -65,7 +65,7 @@
+Index: madwifi-dfs-r3053/ath_rate/sample/sample.c
+===================================================================
+--- madwifi-dfs-r3053.orig/ath_rate/sample/sample.c    2007-12-13 05:25:10.446220763 +0100
++++ madwifi-dfs-r3053/ath_rate/sample/sample.c 2007-12-13 05:25:13.358386718 +0100
+@@ -68,7 +68,7 @@
  
  #include "sample.h"
  
@@ -45,22 +113,11 @@ diff -Nur madwifi-0.9.2.1/ath_rate/sample/sample.c madwifi-0.9.2.1-nodebug/ath_r
 +#undef        SAMPLE_DEBUG
  #ifdef SAMPLE_DEBUG
  enum {
-       ATH_DEBUG_RATE          = 0x00000010    /* rate control */
-diff -Nur madwifi-0.9.2.1/net80211/ieee80211_var.h madwifi-0.9.2.1-nodebug/net80211/ieee80211_var.h
---- madwifi-0.9.2.1/net80211/ieee80211_var.h   2006-07-06 05:23:08.000000000 +0200
-+++ madwifi-0.9.2.1-nodebug/net80211/ieee80211_var.h   2007-02-20 11:43:09.000000000 +0100
-@@ -37,7 +37,7 @@
- /*
-  * Definitions for IEEE 802.11 drivers.
-  */
--#define       IEEE80211_DEBUG
-+#undef        IEEE80211_DEBUG
- #undef        IEEE80211_DEBUG_REFCNT                  /* node refcnt stuff */
- #include <net80211/ieee80211_linux.h>
-diff -Nur madwifi-0.9.2.1/tools/do_multi.c madwifi-0.9.2.1-nodebug/tools/do_multi.c
---- madwifi-0.9.2.1/tools/do_multi.c   2007-02-20 11:53:44.000000000 +0100
-+++ madwifi-0.9.2.1-nodebug/tools/do_multi.c   2007-02-20 11:58:22.000000000 +0100
+       ATH_DEBUG_RATE          = 0x00000010,   /* rate control */
+Index: madwifi-dfs-r3053/tools/do_multi.c
+===================================================================
+--- madwifi-dfs-r3053.orig/tools/do_multi.c    2007-12-13 05:25:11.242266126 +0100
++++ madwifi-dfs-r3053/tools/do_multi.c 2007-12-13 05:25:13.362386947 +0100
 @@ -9,16 +9,20 @@
  
      progname = basename(argv[0]);
@@ -82,24 +139,40 @@ diff -Nur madwifi-0.9.2.1/tools/do_multi.c madwifi-0.9.2.1-nodebug/tools/do_mult
      if(strcmp(progname, "athkey") == 0)
        ret =  athkey_init(argc, argv);
      if(strcmp(progname, "athstats") == 0)
-diff -Nur madwifi-0.9.2.1/tools/Makefile madwifi-0.9.2.1-nodebug/tools/Makefile
---- madwifi-0.9.2.1/tools/Makefile     2007-02-20 11:53:44.000000000 +0100
-+++ madwifi-0.9.2.1-nodebug/tools/Makefile     2007-02-20 11:57:23.000000000 +0100
-@@ -52,7 +52,7 @@
-       
- ifdef DOMULTI
- OBJS= do_multi.o athstats.o 80211stats.o athkey.o athchans.o athctrl.o \
--      athdebug.o 80211debug.o wlanconfig.o 
-+      wlanconfig.o 
- ALL=  ${OBJS} madwifi_multi
- endif
+Index: madwifi-dfs-r3053/tools/Makefile
+===================================================================
+--- madwifi-dfs-r3053.orig/tools/Makefile      2007-12-13 05:25:11.246266355 +0100
++++ madwifi-dfs-r3053/tools/Makefile   2007-12-13 05:25:13.362386947 +0100
+@@ -48,7 +48,7 @@
  
-@@ -85,7 +85,7 @@
+ ALLPROGS=     athstats 80211stats athkey athchans athctrl \
+-      athdebug 80211debug wlanconfig ath_info
++      wlanconfig ath_info
+ OBJS= $(patsubst %,%.o,$(ALLPROGS) do_multi)
+ ALL=  ${OBJS} madwifi_multi
+@@ -84,7 +84,7 @@
        ${CC} -c -o do_multi.o -DDOMULTI=1 ${ALL_CFLAGS} do_multi.c
- madwifi_multi:
+ madwifi_multi: $(OBJS)
        ${CC} -o madwifi_multi ${LDFLAGS} ${OBJS}
 -      for i in athstats 80211stats athkey athchans athctrl athdebug wlanconfig 80211debug; do \
 +      for i in athstats 80211stats athkey athchans athctrl wlanconfig; do \
        ln -s -f madwifi_multi $$i; \
        done
  
+Index: madwifi-dfs-r3053/net80211/ieee80211_linux.h
+===================================================================
+--- madwifi-dfs-r3053.orig/net80211/ieee80211_linux.h  2007-12-13 05:25:10.470222132 +0100
++++ madwifi-dfs-r3053/net80211/ieee80211_linux.h       2007-12-13 05:25:13.362386947 +0100
+@@ -29,8 +29,8 @@
+ #ifndef _NET80211_IEEE80211_LINUX_H_
+ #define _NET80211_IEEE80211_LINUX_H_
+-#define       IEEE80211_DEBUG
+-#define       IEEE80211_DEBUG_REFCNT                  /* Node reference count debugging */
++#undef        IEEE80211_DEBUG
++#undef        IEEE80211_DEBUG_REFCNT                  /* Node reference count debugging */
+ /* #define ATH_DEBUG_SPINLOCKS */             /* announce before spinlocking */
+ #include <linux/wireless.h>