oops, applied the ipkg patch with the wrong patchlevel
[openwrt.git] / package / madwifi / patches / 200-no_debug.patch
index b1830c66d2518008d63a93d132b5c4a49a09a7f7..a54b33d529db6510598a1c23ed63569df66b0eaa 100644 (file)
@@ -1,20 +1,71 @@
-Index: madwifi-ng-r2568-20070710/ath/if_ath.c
+Index: madwifi-dfs-r3053/ath/if_ath.c
 ===================================================================
---- madwifi-ng-r2568-20070710.orig/ath/if_ath.c        2007-07-23 01:48:43.942484311 +0200
-+++ madwifi-ng-r2568-20070710/ath/if_ath.c     2007-07-23 01:48:44.466514171 +0200
-@@ -75,7 +75,7 @@
- #include <net80211/if_llc.h>
- #endif
+--- madwifi-dfs-r3053.orig/ath/if_ath.c        2007-12-13 05:25:13.122373270 +0100
++++ madwifi-dfs-r3053/ath/if_ath.c     2007-12-13 05:25:13.342385808 +0100
+@@ -42,7 +42,7 @@
+  * This software is derived from work of Atsushi Onoe; his contribution
+  * is greatly appreciated.
+  */
 -#define       AR_DEBUG
 +#undef        AR_DEBUG
+ #include "if_ath_debug.h"
+ #include "opt_ah.h"
+@@ -516,9 +516,11 @@
+       u_int8_t csz;
+       sc->devid = devid;
++#ifdef AR_DEBUG
+       ath_debug_global = (ath_debug & ATH_DEBUG_GLOBAL);
+       sc->sc_debug     = (ath_debug & ~ATH_DEBUG_GLOBAL);
+       DPRINTF(sc, ATH_DEBUG_ANY, "%s: devid 0x%x\n", __func__, devid);
++#endif
  
- #include "net80211/if_athproto.h"
- #include "if_athvar.h"
-Index: madwifi-ng-r2568-20070710/ath_rate/amrr/amrr.c
+       /*
+        * Cache line size is used to size and align various
+@@ -1280,12 +1282,14 @@
+               /* If no default VAP debug flags are passed, allow a few to
+                * transfer down from the driver to new VAPs so we can have load
+                * time debugging for VAPs too. */
++#ifdef AR_DEBUG
+               vap->iv_debug = 0 |
+                       ((sc->sc_debug & ATH_DEBUG_RATE) ? IEEE80211_MSG_XRATE  : 0) | 
+                       ((sc->sc_debug & ATH_DEBUG_XMIT) ? IEEE80211_MSG_OUTPUT : 0) | 
+                       ((sc->sc_debug & ATH_DEBUG_RECV) ? IEEE80211_MSG_INPUT  : 0) |
+                       0
+                       ;
++#endif
+       }
+       ic->ic_debug = (sc->sc_default_ieee80211_debug & IEEE80211_MSG_IC);
+@@ -10308,9 +10312,11 @@
+                               /* XXX validate? */
+                               sc->sc_ledpin = val;
+                               break;
++#ifdef AR_DEBUG
+                       case ATH_DEBUG:
+                               sc->sc_debug     = (val & ~ATH_DEBUG_GLOBAL);
+                               ath_debug_global = (val &  ATH_DEBUG_GLOBAL);
++#endif
+                               break;
+                       case ATH_TXANTENNA:
+                               /*
+@@ -10721,9 +10727,11 @@
+       }
+       /* initialize values */
++#ifdef AR_DEBUG
+       ath_debug_global = (ath_debug & ATH_DEBUG_GLOBAL);
+       sc->sc_debug     = (ath_debug & ~ATH_DEBUG_GLOBAL);
+       sc->sc_default_ieee80211_debug = ieee80211_debug;
++#endif
+       sc->sc_txantenna = 0;           /* default to auto-selection */
+       sc->sc_txintrperiod = ATH_TXQ_INTR_PERIOD;
+ }
+Index: madwifi-dfs-r3053/ath_rate/amrr/amrr.c
 ===================================================================
---- madwifi-ng-r2568-20070710.orig/ath_rate/amrr/amrr.c        2007-07-23 01:48:37.298105667 +0200
-+++ madwifi-ng-r2568-20070710/ath_rate/amrr/amrr.c     2007-07-23 01:48:44.470514400 +0200
+--- madwifi-dfs-r3053.orig/ath_rate/amrr/amrr.c        2007-12-13 05:25:10.422219395 +0100
++++ madwifi-dfs-r3053/ath_rate/amrr/amrr.c     2007-12-13 05:25:13.342385808 +0100
 @@ -70,7 +70,7 @@
  
  #include "amrr.h"
@@ -24,10 +75,10 @@ Index: madwifi-ng-r2568-20070710/ath_rate/amrr/amrr.c
  #ifdef AMRR_DEBUG
  #define       DPRINTF(sc, _fmt, ...) do {                                     \
        if (sc->sc_debug & 0x10)                                        \
-Index: madwifi-ng-r2568-20070710/ath_rate/minstrel/minstrel.c
+Index: madwifi-dfs-r3053/ath_rate/minstrel/minstrel.c
 ===================================================================
---- madwifi-ng-r2568-20070710.orig/ath_rate/minstrel/minstrel.c        2007-07-23 01:48:40.974315165 +0200
-+++ madwifi-ng-r2568-20070710/ath_rate/minstrel/minstrel.c     2007-07-23 01:48:44.494515770 +0200
+--- madwifi-dfs-r3053.orig/ath_rate/minstrel/minstrel.c        2007-12-13 05:25:12.006309667 +0100
++++ madwifi-dfs-r3053/ath_rate/minstrel/minstrel.c     2007-12-13 05:25:13.350386263 +0100
 @@ -117,7 +117,7 @@
  
  #include "minstrel.h"
@@ -37,10 +88,10 @@ Index: madwifi-ng-r2568-20070710/ath_rate/minstrel/minstrel.c
  #ifdef MINSTREL_DEBUG
  enum {
                ATH_DEBUG_RATE          = 0x00000010    /* rate control */
-Index: madwifi-ng-r2568-20070710/ath_rate/onoe/onoe.c
+Index: madwifi-dfs-r3053/ath_rate/onoe/onoe.c
 ===================================================================
---- madwifi-ng-r2568-20070710.orig/ath_rate/onoe/onoe.c        2007-07-23 01:48:37.314106578 +0200
-+++ madwifi-ng-r2568-20070710/ath_rate/onoe/onoe.c     2007-07-23 01:48:44.518517136 +0200
+--- madwifi-dfs-r3053.orig/ath_rate/onoe/onoe.c        2007-12-13 05:25:10.438220308 +0100
++++ madwifi-dfs-r3053/ath_rate/onoe/onoe.c     2007-12-13 05:25:13.354386489 +0100
 @@ -66,7 +66,7 @@
  
  #include "onoe.h"
@@ -50,10 +101,10 @@ Index: madwifi-ng-r2568-20070710/ath_rate/onoe/onoe.c
  #ifdef ONOE_DEBUG
  enum {
        ATH_DEBUG_RATE  = 0x00000010,   /* rate control */
-Index: madwifi-ng-r2568-20070710/ath_rate/sample/sample.c
+Index: madwifi-dfs-r3053/ath_rate/sample/sample.c
 ===================================================================
---- madwifi-ng-r2568-20070710.orig/ath_rate/sample/sample.c    2007-07-23 01:48:37.322107035 +0200
-+++ madwifi-ng-r2568-20070710/ath_rate/sample/sample.c 2007-07-23 01:48:44.546518731 +0200
+--- madwifi-dfs-r3053.orig/ath_rate/sample/sample.c    2007-12-13 05:25:10.446220763 +0100
++++ madwifi-dfs-r3053/ath_rate/sample/sample.c 2007-12-13 05:25:13.358386718 +0100
 @@ -68,7 +68,7 @@
  
  #include "sample.h"
@@ -62,46 +113,11 @@ Index: madwifi-ng-r2568-20070710/ath_rate/sample/sample.c
 +#undef        SAMPLE_DEBUG
  #ifdef SAMPLE_DEBUG
  enum {
-       ATH_DEBUG_NODE          = 0x00080000,   /* node management */
-Index: madwifi-ng-r2568-20070710/net80211/ieee80211_proto.c
+       ATH_DEBUG_RATE          = 0x00000010,   /* rate control */
+Index: madwifi-dfs-r3053/tools/do_multi.c
 ===================================================================
---- madwifi-ng-r2568-20070710.orig/net80211/ieee80211_proto.c  2007-07-23 01:48:37.330107492 +0200
-+++ madwifi-ng-r2568-20070710/net80211/ieee80211_proto.c       2007-07-23 01:48:44.570520097 +0200
-@@ -286,6 +286,7 @@
- }
- EXPORT_SYMBOL(ieee80211_aclator_get);
-+#ifdef IEEE80211_DEBUG
- void
- ieee80211_print_essid(const u_int8_t *essid, int len)
- {
-@@ -312,7 +313,6 @@
- }
- EXPORT_SYMBOL(ieee80211_print_essid);
--#ifdef IEEE80211_DEBUG
- void
- ieee80211_dump_pkt(struct ieee80211com *ic,
-       const u_int8_t *buf, int len, int rate, int rssi)
-Index: madwifi-ng-r2568-20070710/net80211/ieee80211_var.h
-===================================================================
---- madwifi-ng-r2568-20070710.orig/net80211/ieee80211_var.h    2007-07-23 01:48:37.338107946 +0200
-+++ madwifi-ng-r2568-20070710/net80211/ieee80211_var.h 2007-07-23 01:48:44.622523064 +0200
-@@ -35,8 +35,8 @@
- #ifndef _NET80211_IEEE80211_VAR_H_
- #define _NET80211_IEEE80211_VAR_H_
--#define       IEEE80211_DEBUG
--#define       IEEE80211_DEBUG_REFCNT                  /* Node reference count debugging */
-+#undef        IEEE80211_DEBUG
-+#undef        IEEE80211_DEBUG_REFCNT                  /* Node reference count debugging */
- /* Definitions for IEEE 802.11 drivers. */
- #include <net80211/ieee80211_linux.h>
-Index: madwifi-ng-r2568-20070710/tools/do_multi.c
-===================================================================
---- madwifi-ng-r2568-20070710.orig/tools/do_multi.c    2007-07-23 01:48:39.754245634 +0200
-+++ madwifi-ng-r2568-20070710/tools/do_multi.c 2007-07-23 01:48:44.650524656 +0200
+--- madwifi-dfs-r3053.orig/tools/do_multi.c    2007-12-13 05:25:11.242266126 +0100
++++ madwifi-dfs-r3053/tools/do_multi.c 2007-12-13 05:25:13.362386947 +0100
 @@ -9,16 +9,20 @@
  
      progname = basename(argv[0]);
@@ -123,25 +139,40 @@ Index: madwifi-ng-r2568-20070710/tools/do_multi.c
      if(strcmp(progname, "athkey") == 0)
        ret =  athkey_init(argc, argv);
      if(strcmp(progname, "athstats") == 0)
-Index: madwifi-ng-r2568-20070710/tools/Makefile
+Index: madwifi-dfs-r3053/tools/Makefile
 ===================================================================
---- madwifi-ng-r2568-20070710.orig/tools/Makefile      2007-07-23 01:48:39.798248141 +0200
-+++ madwifi-ng-r2568-20070710/tools/Makefile   2007-07-23 01:48:44.670525796 +0200
-@@ -52,7 +52,7 @@
-       
- ifdef DOMULTI
- OBJS= do_multi.o athstats.o 80211stats.o athkey.o athchans.o athctrl.o \
--      athdebug.o 80211debug.o wlanconfig.o
-+      wlanconfig.o
- ALL=  ${OBJS} madwifi_multi
- endif
+--- madwifi-dfs-r3053.orig/tools/Makefile      2007-12-13 05:25:11.246266355 +0100
++++ madwifi-dfs-r3053/tools/Makefile   2007-12-13 05:25:13.362386947 +0100
+@@ -48,7 +48,7 @@
  
-@@ -85,7 +85,7 @@
+ ALLPROGS=     athstats 80211stats athkey athchans athctrl \
+-      athdebug 80211debug wlanconfig ath_info
++      wlanconfig ath_info
+ OBJS= $(patsubst %,%.o,$(ALLPROGS) do_multi)
+ ALL=  ${OBJS} madwifi_multi
+@@ -84,7 +84,7 @@
        ${CC} -c -o do_multi.o -DDOMULTI=1 ${ALL_CFLAGS} do_multi.c
- madwifi_multi:
+ madwifi_multi: $(OBJS)
        ${CC} -o madwifi_multi ${LDFLAGS} ${OBJS}
 -      for i in athstats 80211stats athkey athchans athctrl athdebug wlanconfig 80211debug; do \
 +      for i in athstats 80211stats athkey athchans athctrl wlanconfig; do \
        ln -s -f madwifi_multi $$i; \
        done
  
+Index: madwifi-dfs-r3053/net80211/ieee80211_linux.h
+===================================================================
+--- madwifi-dfs-r3053.orig/net80211/ieee80211_linux.h  2007-12-13 05:25:10.470222132 +0100
++++ madwifi-dfs-r3053/net80211/ieee80211_linux.h       2007-12-13 05:25:13.362386947 +0100
+@@ -29,8 +29,8 @@
+ #ifndef _NET80211_IEEE80211_LINUX_H_
+ #define _NET80211_IEEE80211_LINUX_H_
+-#define       IEEE80211_DEBUG
+-#define       IEEE80211_DEBUG_REFCNT                  /* Node reference count debugging */
++#undef        IEEE80211_DEBUG
++#undef        IEEE80211_DEBUG_REFCNT                  /* Node reference count debugging */
+ /* #define ATH_DEBUG_SPINLOCKS */             /* announce before spinlocking */
+ #include <linux/wireless.h>