ath9k: add support for more antenna mask combinations on AR93xx
[openwrt.git] / package / mac80211 / patches / 400-ath_move_debug_code.patch
index 25842988361ee8611ced94e42fd54d8eac4c69cc..c91128db61d994988b6c4700acfd6c718ab81913 100644 (file)
@@ -1,11 +1,28 @@
 --- a/drivers/net/wireless/ath/Makefile
 +++ b/drivers/net/wireless/ath/Makefile
-@@ -8,6 +8,5 @@ obj-$(CONFIG_ATH_COMMON)       += ath.o
+@@ -10,7 +10,7 @@ obj-$(CONFIG_ATH_COMMON)     += ath.o
  ath-objs :=   main.o \
                regd.o \
                hw.o \
 -              key.o
--
--ath-$(CONFIG_ATH_DEBUG) += debug.o
 +              key.o \
 +              debug.o
+-ath-$(CONFIG_ATH_DEBUG) += debug.o
+ ccflags-y += -D__CHECK_ENDIAN__
+--- a/drivers/net/wireless/ath/ath.h
++++ b/drivers/net/wireless/ath/ath.h
+@@ -281,13 +281,6 @@ void _ath_dbg(struct ath_common *common,
+ #endif /* CONFIG_ATH_DEBUG */
+ /** Returns string describing opmode, or NULL if unknown mode. */
+-#ifdef CONFIG_ATH_DEBUG
+ const char *ath_opmode_to_string(enum nl80211_iftype opmode);
+-#else
+-static inline const char *ath_opmode_to_string(enum nl80211_iftype opmode)
+-{
+-      return "UNKNOWN";
+-}
+-#endif
+ #endif /* ATH_H */