mac80211: fix ad-hoc mode performance regression
[openwrt.git] / package / mac80211 / patches / 007-remove_misc_drivers.patch
index 1181c42af55137e448ceab067b85ac772c282d46..750b95d2d280dec8bfb610853caea0a932fe3296 100644 (file)
@@ -1,6 +1,6 @@
 --- a/config.mk
 +++ b/config.mk
-@@ -252,7 +252,7 @@ $(warning "WARNING: CONFIG_CFG80211_WEXT
+@@ -242,7 +242,7 @@ $(warning "WARNING: CONFIG_CFG80211_WEXT
  endif #CONFIG_WIRELESS_EXT
  
  ifdef CONFIG_STAGING
@@ -9,7 +9,7 @@
  endif #CONFIG_STAGING
  
  # mac80211 test driver
-@@ -406,13 +406,13 @@ endif #CONFIG_CRC_ITU_T
+@@ -396,15 +396,15 @@ endif #CONFIG_CRC_ITU_T
  CONFIG_MWL8K=m
  
  # Ethernet drivers go here
 +# CONFIG_ATL1E=m
  ifdef CONFIG_COMPAT_KERNEL_2_6_27
 -CONFIG_ATL1C=n
+-CONFIG_ALX=m
 +# CONFIG_ATL1C=n
++# CONFIG_ALX=m
  else #CONFIG_COMPAT_KERNEL_2_6_27
--CONFIG_ATL1C=m
-+# CONFIG_ATL1C=m
+-CONFIG_ATL1C=n
+-CONFIG_ALX=m
++# CONFIG_ATL1C=n
++# CONFIG_ALX=m
  endif #CONFIG_COMPAT_KERNEL_2_6_27
  
  ifdef CONFIG_WIRELESS_EXT
-@@ -471,21 +471,21 @@ endif #CONFIG_COMPAT_KERNEL_2_6_29
+@@ -465,21 +465,21 @@ endif #CONFIG_COMPAT_KERNEL_2_6_29
  # Note: this depends on CONFIG_USB_NET_RNDIS_HOST and CONFIG_USB_NET_CDCETHER
  # it also requires new RNDIS_HOST and CDC_ETHER modules which we add
  ifdef CONFIG_COMPAT_KERNEL_2_6_29