ath9k: fix spurious MIC failure detection, causing instability issues in AP mode
[openwrt.git] / package / mac80211 / patches / 002-disable_rfkill.patch
index c935fddf3505aacd6e14aa03879df731408e8703..c5d1ccc507c18461bc24540a7fbd6f5c3bdc846f 100644 (file)
@@ -1,9 +1,18 @@
 --- a/config.mk
 +++ b/config.mk
-@@ -421,8 +421,8 @@ endif
+@@ -72,7 +72,7 @@ endif # build check
+ endif # kernel Makefile check
+ # These both are needed by compat-wireless || compat-bluetooth so enable them
+- CONFIG_COMPAT_RFKILL=y
++# CONFIG_COMPAT_RFKILL=y
+ ifeq ($(CONFIG_MAC80211),y)
+ $(error "ERROR: you have MAC80211 compiled into the kernel, CONFIG_MAC80211=y, as such you cannot replace its mac80211 driver. You need this set to CONFIG_MAC80211=m. If you are using Fedora upgrade your kernel as later version should this set as modular. For further information on Fedora see https://bugzilla.redhat.com/show_bug.cgi?id=470143. If you are using your own kernel recompile it and make mac80211 modular")
+@@ -495,8 +495,8 @@ endif
  # We need the backported rfkill module on kernel < 2.6.31.
  # In more recent kernel versions use the in kernel rfkill module.
- ifdef CONFIG_COMPAT_WIRELESS_31
+ ifdef CONFIG_COMPAT_KERNEL_31
 -CONFIG_RFKILL_BACKPORT=m
 -CONFIG_RFKILL_BACKPORT_LEDS=y
 -CONFIG_RFKILL_BACKPORT_INPUT=y