[ifxmips]
[openwrt.git] / package / linux-atm / patches / 200-no_libfl.patch
index ea6bb0571a6d4920a67c866d18b97cf99cc213fc..4a95c9ae2d1739f1fd371681453cb92ff9033a09 100644 (file)
@@ -1,8 +1,6 @@
-Index: linux-atm-2.5.1/src/qgen/Makefile.am
-===================================================================
---- linux-atm-2.5.1.orig/src/qgen/Makefile.am  2010-02-27 01:36:10.156687492 +0100
-+++ linux-atm-2.5.1/src/qgen/Makefile.am       2010-02-27 01:36:23.388686762 +0100
-@@ -2,7 +2,7 @@
+--- a/src/qgen/Makefile.am
++++ b/src/qgen/Makefile.am
+@@ -2,7 +2,7 @@ noinst_PROGRAMS = qgen
  
  qgen_SOURCES = common.c common.h file.c file.h first.c ql_y.y ql_l.l qgen.c \
                qgen.h second.c third.c
@@ -11,11 +9,9 @@ Index: linux-atm-2.5.1/src/qgen/Makefile.am
  
  CC = @CC_FOR_BUILD@
  CFLAGS = @CFLAGS_FOR_BUILD@
-Index: linux-atm-2.5.1/src/qgen/Makefile.in
-===================================================================
---- linux-atm-2.5.1.orig/src/qgen/Makefile.in  2010-02-27 01:36:10.156687492 +0100
-+++ linux-atm-2.5.1/src/qgen/Makefile.in       2010-02-27 02:06:38.992684137 +0100
-@@ -58,7 +58,7 @@
+--- a/src/qgen/Makefile.in
++++ b/src/qgen/Makefile.in
+@@ -58,7 +58,7 @@ depcomp = $(SHELL) $(top_srcdir)/depcomp
  am__depfiles_maybe = depfiles
  am__mv = mv -f
  COMPILE = $(CC) $(DEFS) $(DEFAULT_INCLUDES) $(INCLUDES) $(AM_CPPFLAGS) \
@@ -24,7 +20,7 @@ Index: linux-atm-2.5.1/src/qgen/Makefile.in
  LTCOMPILE = $(LIBTOOL) --tag=CC $(AM_LIBTOOLFLAGS) $(LIBTOOLFLAGS) \
        --mode=compile $(CC) $(DEFS) $(DEFAULT_INCLUDES) $(INCLUDES) \
        $(AM_CPPFLAGS) $(CPPFLAGS) $(AM_CFLAGS) $(CFLAGS)
-@@ -208,7 +208,7 @@
+@@ -208,7 +208,7 @@ top_srcdir = @top_srcdir@
  qgen_SOURCES = common.c common.h file.c file.h first.c ql_y.y ql_l.l qgen.c \
                qgen.h second.c third.c
  
@@ -33,42 +29,9 @@ Index: linux-atm-2.5.1/src/qgen/Makefile.in
  
  #TESTS = $(check_PROGRAMS)
  EXTRA_DIST = ql_y.h ql_y.c ql_l.c
-Index: linux-atm-2.5.1/src/qgen/ql_l.c
-===================================================================
---- linux-atm-2.5.1.orig/src/qgen/ql_l.c       2010-02-27 01:36:22.669685751 +0100
-+++ linux-atm-2.5.1/src/qgen/ql_l.c    2010-02-27 01:36:23.392683892 +0100
-@@ -514,6 +514,11 @@
- #include "qgen.h"
- #include "ql_y.h"
-+int yywrap(void)
-+{
-+        return 1;
-+}
-+
- typedef struct _tree {
-     struct _tree *left,*right;
-Index: linux-atm-2.5.1/src/sigd/cfg_l.c
-===================================================================
---- linux-atm-2.5.1.orig/src/sigd/cfg_l.c      2010-02-27 01:36:22.673681076 +0100
-+++ linux-atm-2.5.1/src/sigd/cfg_l.c   2010-02-27 01:36:23.392683892 +0100
-@@ -617,6 +617,10 @@
- #include "cfg_y.h"
-+int yywrap(void)
-+{
-+        return 1;
-+}
- static int lineno = 1;
- static int token; /* f@#%ing flex doesn't grok return after BEGIN */
-Index: linux-atm-2.5.1/src/sigd/Makefile.am
-===================================================================
---- linux-atm-2.5.1.orig/src/sigd/Makefile.am  2010-02-27 01:36:10.160686786 +0100
-+++ linux-atm-2.5.1/src/sigd/Makefile.am       2010-02-27 01:36:23.392683892 +0100
-@@ -8,7 +8,7 @@
+--- a/src/sigd/Makefile.am
++++ b/src/sigd/Makefile.am
+@@ -8,7 +8,7 @@ atmsigd_XTRAS = mess.o $(top_builddir)/s
                        $(top_builddir)/src/q2931/qd.dump.o \
                        $(top_builddir)/src/lib/libatm.la \
                        $(top_builddir)/src/saal/libsaal.a
@@ -77,11 +40,9 @@ Index: linux-atm-2.5.1/src/sigd/Makefile.am
  atmsigd_DEPENDENCIES = mess.c $(atmsigd_XTRAS)
  
  CLEANFILES = mess.c
-Index: linux-atm-2.5.1/src/sigd/Makefile.in
-===================================================================
---- linux-atm-2.5.1.orig/src/sigd/Makefile.in  2010-02-27 01:36:10.160686786 +0100
-+++ linux-atm-2.5.1/src/sigd/Makefile.in       2010-02-27 01:36:23.396685195 +0100
-@@ -244,7 +244,7 @@
+--- a/src/sigd/Makefile.in
++++ b/src/sigd/Makefile.in
+@@ -244,7 +244,7 @@ atmsigd_XTRAS = mess.o $(top_builddir)/s
                        $(top_builddir)/src/lib/libatm.la \
                        $(top_builddir)/src/saal/libsaal.a
  
@@ -90,10 +51,8 @@ Index: linux-atm-2.5.1/src/sigd/Makefile.in
  atmsigd_DEPENDENCIES = mess.c $(atmsigd_XTRAS)
  CLEANFILES = mess.c
  sysconf_DATA = atmsigd.conf
-Index: linux-atm-2.5.1/src/switch/debug/debug.c
-===================================================================
---- linux-atm-2.5.1.orig/src/switch/debug/debug.c      2010-02-27 01:36:10.160686786 +0100
-+++ linux-atm-2.5.1/src/switch/debug/debug.c   2010-02-27 01:36:23.396685195 +0100
+--- a/src/switch/debug/debug.c
++++ b/src/switch/debug/debug.c
 @@ -20,6 +20,11 @@
  
  #define PRV(call) ((FAB *) (call)->fab)
@@ -106,11 +65,9 @@ Index: linux-atm-2.5.1/src/switch/debug/debug.c
  
  typedef struct _fab {
      CALL *next; /* relay.c may not keep track of calls, but WE are */
-Index: linux-atm-2.5.1/src/switch/debug/Makefile.am
-===================================================================
---- linux-atm-2.5.1.orig/src/switch/debug/Makefile.am  2010-02-27 01:36:10.164686879 +0100
-+++ linux-atm-2.5.1/src/switch/debug/Makefile.am       2010-02-27 01:36:23.396685195 +0100
-@@ -5,7 +5,7 @@
+--- a/src/switch/debug/Makefile.am
++++ b/src/switch/debug/Makefile.am
+@@ -5,7 +5,7 @@ INCLUDES = -I$(srcdir)/../../q2931
  sw_debug_SOURCES = debug.c
  sw_debug_XTRAS = $(top_builddir)/src/switch/libsw.a \
                        $(top_builddir)/src/lib/libatm.la
@@ -119,11 +76,9 @@ Index: linux-atm-2.5.1/src/switch/debug/Makefile.am
                        
  sw_debug_DEPENDENCIES = $(sw_debug_XTRAS)
  
-Index: linux-atm-2.5.1/src/switch/debug/Makefile.in
-===================================================================
---- linux-atm-2.5.1.orig/src/switch/debug/Makefile.in  2010-02-27 01:36:10.164686879 +0100
-+++ linux-atm-2.5.1/src/switch/debug/Makefile.in       2010-02-27 01:36:23.396685195 +0100
-@@ -199,7 +199,8 @@
+--- a/src/switch/debug/Makefile.in
++++ b/src/switch/debug/Makefile.in
+@@ -199,7 +199,8 @@ sw_debug_SOURCES = debug.c
  sw_debug_XTRAS = $(top_builddir)/src/switch/libsw.a \
                        $(top_builddir)/src/lib/libatm.la
  
@@ -133,11 +88,9 @@ Index: linux-atm-2.5.1/src/switch/debug/Makefile.in
  sw_debug_DEPENDENCIES = $(sw_debug_XTRAS)
  EXTRA_DIST = demo README
  all: all-am
-Index: linux-atm-2.5.1/src/switch/tcp/Makefile.am
-===================================================================
---- linux-atm-2.5.1.orig/src/switch/tcp/Makefile.am    2010-02-27 01:36:10.201682113 +0100
-+++ linux-atm-2.5.1/src/switch/tcp/Makefile.am 2010-02-27 01:36:23.412882977 +0100
-@@ -5,7 +5,7 @@
+--- a/src/switch/tcp/Makefile.am
++++ b/src/switch/tcp/Makefile.am
+@@ -5,7 +5,7 @@ INCLUDES = -I$(srcdir)/../../q2931
  sw_tcp_SOURCES = tcpsw.c
  sw_tcp_XTRAS = $(top_builddir)/src/switch/libsw.a \
                $(top_builddir)/src/lib/libatm.la
@@ -146,11 +99,9 @@ Index: linux-atm-2.5.1/src/switch/tcp/Makefile.am
  sw_tcp_DEPENDENCIES = $(sw_tcp_XTRAS)
  
  EXTRA_DIST = mkfiles README
-Index: linux-atm-2.5.1/src/switch/tcp/Makefile.in
-===================================================================
---- linux-atm-2.5.1.orig/src/switch/tcp/Makefile.in    2010-02-27 01:36:10.209681349 +0100
-+++ linux-atm-2.5.1/src/switch/tcp/Makefile.in 2010-02-27 01:36:23.417680887 +0100
-@@ -199,7 +199,7 @@
+--- a/src/switch/tcp/Makefile.in
++++ b/src/switch/tcp/Makefile.in
+@@ -199,7 +199,7 @@ sw_tcp_SOURCES = tcpsw.c
  sw_tcp_XTRAS = $(top_builddir)/src/switch/libsw.a \
                $(top_builddir)/src/lib/libatm.la
  
@@ -159,10 +110,8 @@ Index: linux-atm-2.5.1/src/switch/tcp/Makefile.in
  sw_tcp_DEPENDENCIES = $(sw_tcp_XTRAS)
  EXTRA_DIST = mkfiles README
  all: all-am
-Index: linux-atm-2.5.1/src/switch/tcp/tcpsw.c
-===================================================================
---- linux-atm-2.5.1.orig/src/switch/tcp/tcpsw.c        2010-02-27 01:36:10.221684444 +0100
-+++ linux-atm-2.5.1/src/switch/tcp/tcpsw.c     2010-02-27 01:36:23.428680415 +0100
+--- a/src/switch/tcp/tcpsw.c
++++ b/src/switch/tcp/tcpsw.c
 @@ -35,6 +35,10 @@
  #define MAX_PACKET (ATM_MAX_AAL5_PDU+sizeof(struct atmtcp_hdr))
  #define BUFFER_SIZE (MAX_PACKET*2)
@@ -174,27 +123,9 @@ Index: linux-atm-2.5.1/src/switch/tcp/tcpsw.c
  
  typedef struct _table {
      struct _link *out;        /* output port */
-Index: linux-atm-2.5.1/src/test/ispl_l.c
-===================================================================
---- linux-atm-2.5.1.orig/src/test/ispl_l.c     2010-02-27 01:36:22.677681892 +0100
-+++ linux-atm-2.5.1/src/test/ispl_l.c  2010-02-27 01:36:23.428680415 +0100
-@@ -629,6 +629,11 @@
- #include "isp.h"
- #include "ispl_y.h"
-+int yywrap(void)
-+{
-+      return 1;
-+}
-+
- static int lineno = 1;
-Index: linux-atm-2.5.1/src/test/Makefile.am
-===================================================================
---- linux-atm-2.5.1.orig/src/test/Makefile.am  2010-02-27 01:36:10.221684444 +0100
-+++ linux-atm-2.5.1/src/test/Makefile.am       2010-02-27 01:36:23.428680415 +0100
-@@ -20,7 +20,7 @@
+--- a/src/test/Makefile.am
++++ b/src/test/Makefile.am
+@@ -20,7 +20,7 @@ br_SOURCES = br.c
  bw_SOURCES = bw.c
  isp_SOURCES = isp.c isp.h ispl_y.y ispl_l.l
  isp_XTRAS = $(LDADD)
@@ -203,11 +134,9 @@ Index: linux-atm-2.5.1/src/test/Makefile.am
  isp_DEPENDENCIES = $(isp_XTRAS)
  window_SOURCES = window.c
  
-Index: linux-atm-2.5.1/src/test/Makefile.in
-===================================================================
---- linux-atm-2.5.1.orig/src/test/Makefile.in  2010-02-27 01:36:10.225688778 +0100
-+++ linux-atm-2.5.1/src/test/Makefile.in       2010-02-27 01:36:23.432685583 +0100
-@@ -282,7 +282,7 @@
+--- a/src/test/Makefile.in
++++ b/src/test/Makefile.in
+@@ -282,7 +282,7 @@ br_SOURCES = br.c
  bw_SOURCES = bw.c
  isp_SOURCES = isp.c isp.h ispl_y.y ispl_l.l
  isp_XTRAS = $(LDADD)
@@ -216,3 +145,44 @@ Index: linux-atm-2.5.1/src/test/Makefile.in
  isp_DEPENDENCIES = $(isp_XTRAS)
  window_SOURCES = window.c
  CLEANFILES = errnos.inc
+--- a/src/test/ispl_l.l
++++ b/src/test/ispl_l.l
+@@ -18,6 +18,11 @@
+ #include "ispl_y.h"
++int yywrap(void)
++{
++       return 1;
++}
++
+ static int lineno = 1;
+ %}
+--- a/src/qgen/ql_l.l
++++ b/src/qgen/ql_l.l
+@@ -11,6 +11,11 @@
+ #include "ql_y.h"
++int yywrap(void)
++{
++        return 1;
++}
++
+ typedef struct _tree {
+     struct _tree *left,*right;
+     const char str[0];
+--- a/src/sigd/cfg_l.l
++++ b/src/sigd/cfg_l.l
+@@ -16,6 +16,10 @@
+ #include "cfg_y.h"
++int yywrap(void)
++{
++        return 1;
++}
+ static int lineno = 1;
+ static int token; /* f@#%ing flex doesn't grok return after BEGIN */