remove uneeded flags, fix shared lib install
[openwrt.git] / package / linux-atm / Makefile
index 3fe9dd0c9deb47f5d4f7d1168bdfeb04ce50e4d0..ffac08b251548dda8b87408f041c31049b711feb 100644 (file)
@@ -18,27 +18,27 @@ PKG_MD5SUM:=84fef49cc39ff2605204246666f65864
 
 include $(INCLUDE_DIR)/package.mk
 
-define Package/linux-atm/Default
-  URL:=http://linux-atm.sourceforge.net/
-endef
-
 define Package/linux-atm
-  $(call Package/linux-atm/Default)
   SECTION:=libs
   CATEGORY:=Libraries
-  TITLE:=Linux ATM Library
-  DESCRIPTION:=\
-       This package contains a library for accessing the Linux ATM subsystem.
+  TITLE:=Linux ATM library
+  URL:=http://linux-atm.sourceforge.net/
+endef
+
+define Package/linux-atm/description
+  This package contains a library for accessing the Linux ATM subsystem.
 endef
 
-define Package/br2684ctl
-  $(call Package/linux-atm/Default)
+define Package/atm-tools
   SECTION:=net
   CATEGORY:=Network
-  DEPENDS:=+linux-atm
-  TITLE:=RFC2684 bridging utility
-  DESCRIPTION:=\
-       This package contains an ATM RFC2684 bridging utility.
+  DEPENDS:=linux-atm
+  TITLE:=Linux ATM tools
+  URL:=http://linux-atm.sourceforge.net/
+endef
+
+define Package/atm-tools/description
+  This package contains the Linux ATM tools.
 endef
 
 define Build/Configure
@@ -47,10 +47,8 @@ define Build/Configure
        touch $(PKG_BUILD_DIR)/stamp-h.in
 endef
 
-TARGET_CFLAGS := -I$(PKG_BUILD_DIR)/src/include $(TARGET_CFLAGS)
 define Build/Compile
        $(MAKE) -C $(PKG_BUILD_DIR) \
-               $(TARGET_CONFIGURE_OPTS) \
                DESTDIR="$(PKG_INSTALL_DIR)" \
                all install
 endef
@@ -71,19 +69,15 @@ endef
 
 define Package/linux-atm/install
        $(INSTALL_DIR) $(1)/usr/lib
-       cp -f $(PKG_INSTALL_DIR)/usr/lib/libatm.so.1 $(1)/usr/lib
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/libatm.so.* $(1)/usr/lib/
 endef
 
-define Package/br2684ctl/install
-       $(INSTALL_DIR) $(1)/usr/sbin
-       $(CP) $(PKG_INSTALL_DIR)/usr/sbin/br2684ctl $(1)/usr/sbin/
-       $(INSTALL_DIR) $(1)/etc/hotplug.d/net
-       $(INSTALL_DATA) ./files/br2684.hotplug $(1)/etc/hotplug.d/net/30-br2684
+define Package/atm-tools/install
+       $(INSTALL_DIR) $(1)/usr/sbin/
+       $(CP) $(PKG_INSTALL_DIR)/usr/sbin/atmarp{,d} $(1)/usr/sbin/
+       $(INSTALL_DIR) $(1)/lib/network
+       $(INSTALL_BIN) ./files/ipoa.sh $(1)/lib/network/
 endef
 
 $(eval $(call BuildPackage,linux-atm))
-$(eval $(call BuildPackage,br2684ctl))
-
-$(eval $(call RequireCommand,automake, \
-       $(PKG_NAME) requires automake. \
-))
+$(eval $(call BuildPackage,atm-tools))