[package] libnl: fix compilation with eglibc (closes: #4785)
[openwrt.git] / package / libpcap / Makefile
index bd039f911dfa5c4b5fbc3fddff91922614086edf..620fdb94bccf4e805d5e0822f413e7b59933550d 100644 (file)
@@ -9,12 +9,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=libpcap
-PKG_VERSION:=0.9.4
+PKG_VERSION:=0.9.8
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://www.tcpdump.org/release/
-PKG_MD5SUM:=79025766e8027df154cb1f32de8a7974
+PKG_MD5SUM:=5208f24d0328ee7c20b52c43eaa9aa0e
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -26,10 +26,13 @@ define Package/libpcap
 endef
 
 define Package/libpcap/description
- This package contains a system-independent library for user-level network 
+ This package contains a system-independent library for user-level network
  packet capture.
 endef
 
+TARGET_CFLAGS += \
+       -ffunction-sections -fdata-sections
+
 CONFIGURE_ARGS += \
        --enable-shared \
        --enable-static \
@@ -54,11 +57,6 @@ define Build/InstallDev
                $(1)/usr/lib/
 endef
 
-define Build/UninstallDev
-       rm -rf  $(1)/usr/include/pcap{,-bpf,-namedb}.h \
-               $(1)/usr/lib/libpcap.{a,so*}
-endef
-
 define Package/libpcap/install
        $(INSTALL_DIR) $(1)/usr/lib
        $(CP) $(PKG_INSTALL_DIR)/usr/lib/libpcap.so.* $(1)/usr/lib/