ath9k: fix cycle counter tracking
[openwrt.git] / package / libnl / Makefile
index d288680ca8baa8459545031151957274a30dd8a7..eb9831a21e1430bcf412dfe7e1368912ee804b92 100644 (file)
@@ -4,7 +4,6 @@
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
@@ -38,18 +37,16 @@ define Build/Compile
                install
 endef
 
-ifneq ($(CONFIG_LINUX_2_6),)
-  define Build/InstallDev
+define Build/InstallDev
        $(INSTALL_DIR) $(1)
        $(CP) $(PKG_INSTALL_DIR)/* $(1)/
        mkdir -p $(1)/usr/include/libnl
        $(CP) $(PKG_BUILD_DIR)/include/linux $(1)/usr/include/libnl/
-  endef
+endef
 
-  define Package/libnl/install
+define Package/libnl/install
        $(INSTALL_DIR) $(1)/usr/lib
        $(CP) $(PKG_INSTALL_DIR)/usr/lib/libnl.so.* $(1)/usr/lib/
-  endef
-endif
+endef
 
 $(eval $(call BuildPackage,libnl))