ath9k: fix a few remaining issues in the xmit queue cleanup patch - reduces packet...
[openwrt.git] / package / kernel / modules / video.mk
index 92a5205c6fcb729340287684e296d2ae83c2b14e..b148afc0e17e13c5696b804ab710253147542fe4 100644 (file)
@@ -11,7 +11,7 @@ VIDEO_MENU:=Video Support
 define KernelPackage/video-core
   SUBMENU:=$(VIDEO_MENU)
   TITLE=Video4Linux support
-  DEPENDS:=@PCI_SUPPORT||USB_SUPPORT
+  DEPENDS:=@PCI_SUPPORT||USB_SUPPORT +!TARGET_etrax:kmod-i2c-core
   KCONFIG:= \
        CONFIG_MEDIA_SUPPORT=m \
        CONFIG_VIDEO_DEV \
@@ -85,9 +85,9 @@ $(eval $(call KernelPackage,video-konica))
 
 
 define KernelPackage/video-ov511
-$(call AddDepends/video,@USB_SUPPORT +kmod-usb-core)
   TITLE:=OV511 USB webcam support
-  KCONFIG:=CONFIG_VIDEO_OV511
+  DEPENDS:=@USB_SUPPORT +kmod-usb-core
+  KCONFIG:=CONFIG_USB_OV511
   FILES:=$(LINUX_DIR)/drivers/media/video/ov511.ko
   AUTOLOAD:=$(call AutoLoad,70,ov511)
   $(call AddDepends/video)
@@ -102,8 +102,8 @@ $(eval $(call KernelPackage,video-ov511))
 
 
 define KernelPackage/video-ovcamchip
-$(call AddDepends/video,@USB_SUPPORT +kmod-i2c-core)
   TITLE:=OV6xxx/OV7xxx Camera Chip support
+  DEPENDS:=@USB_SUPPORT +kmod-usb-core
   KCONFIG:=CONFIG_VIDEO_OVCAMCHIP
   FILES:=$(LINUX_DIR)/drivers/media/video/ovcamchip/ovcamchip.ko
   AUTOLOAD:=$(call AutoLoad,70,ovcamchip)
@@ -120,8 +120,8 @@ $(eval $(call KernelPackage,video-ovcamchip))
 
 
 define KernelPackage/video-sn9c102
-$(call AddDepends/video,@USB_SUPPORT +kmod-usb-core)
   TITLE:=SN9C102 Camera Chip support
+  DEPENDS:=@USB_SUPPORT +kmod-usb-core
   KCONFIG:=CONFIG_USB_SN9C102
   FILES:=$(LINUX_DIR)/drivers/media/video/sn9c102/sn9c102.ko
   AUTOLOAD:=$(call AutoLoad,70,gspca_sn9c20x)
@@ -138,8 +138,8 @@ $(eval $(call KernelPackage,video-sn9c102))
 
 
 define KernelPackage/video-pwc
-$(call AddDepends/video,@USB_SUPPORT +kmod-usb-core)
   TITLE:=Philips USB webcam support
+  DEPENDS:=@USB_SUPPORT +kmod-usb-core
   KCONFIG:= \
        CONFIG_USB_PWC \
        CONFIG_USB_PWC_DEBUG=n
@@ -156,12 +156,13 @@ endef
 $(eval $(call KernelPackage,video-pwc))
 
 define KernelPackage/video-uvc
-$(call AddDepends/video,@USB_SUPPORT +kmod-usb-core)
   TITLE:=USB Video Class (UVC) support
+  DEPENDS:=@USB_SUPPORT +kmod-usb-core
   KCONFIG:= CONFIG_USB_VIDEO_CLASS
   FILES:=$(LINUX_DIR)/drivers/media/video/uvc/uvcvideo.ko
   AUTOLOAD:=$(call AutoLoad,90,uvcvideo)
   $(call AddDepends/video)
+  $(call AddDepends/input)
 endef