Revert "[package] kernel/modules: dont only change loading order on IPSEC*-m, propaga...
[openwrt.git] / package / kernel / modules / spi.mk
index ff24d9f663ac107303c01a1858c6ff821d733312..fc7bce559ab0bd2ef57d8cc162859442842653b8 100644 (file)
@@ -31,13 +31,8 @@ define KernelPackage/spi-bitbang
   KCONFIG:=CONFIG_SPI_BITBANG \
           CONFIG_SPI=y \
           CONFIG_SPI_MASTER=y
-  ifeq ($(strip $(call CompareKernelPatchVer,$(KERNEL_PATCHVER),ge,3.1)),1)
-    FILES:=$(LINUX_DIR)/drivers/spi/spi-bitbang.ko
-    AUTOLOAD:=$(call AutoLoad,91,spi-bitbang)
-  else
-    FILES:=$(LINUX_DIR)/drivers/spi/spi_bitbang.ko
-    AUTOLOAD:=$(call AutoLoad,91,spi_bitbang)
-  endif
+  FILES:=$(LINUX_DIR)/drivers/spi/spi-bitbang.ko
+  AUTOLOAD:=$(call AutoLoad,91,spi-bitbang)
 endef
 
 define KernelPackage/spi-bitbang/description
@@ -67,13 +62,8 @@ define KernelPackage/spi-gpio
   TITLE:=GPIO-based bitbanging SPI Master
   DEPENDS:=@GPIO_SUPPORT +kmod-spi-bitbang
   KCONFIG:=CONFIG_SPI_GPIO
-  ifeq ($(strip $(call CompareKernelPatchVer,$(KERNEL_PATCHVER),ge,3.1)),1)
-    FILES:=$(LINUX_DIR)/drivers/spi/spi-gpio.ko
-    AUTOLOAD:=$(call AutoLoad,92,spi-gpio)
-  else
-    FILES:=$(LINUX_DIR)/drivers/spi/spi_gpio.ko
-    AUTOLOAD:=$(call AutoLoad,92,spi_gpio)
-  endif
+  FILES:=$(LINUX_DIR)/drivers/spi/spi-gpio.ko
+  AUTOLOAD:=$(call AutoLoad,92,spi-gpio)
 endef
 
 define KernelPackage/spi-gpio/description
@@ -104,8 +94,8 @@ define KernelPackage/spi-vsc7385
   TITLE:=Vitesse VSC7385 ethernet switch driver
   DEPENDS:=@TARGET_ar71xx
   KCONFIG:=CONFIG_SPI_VSC7385
-  FILES:=$(LINUX_DIR)/drivers/spi/spi_vsc7385.ko
-  AUTOLOAD:=$(call AutoLoad,93,spi_vsc7385)
+  FILES:=$(LINUX_DIR)/drivers/spi/spi-vsc7385.ko
+  AUTOLOAD:=$(call AutoLoad,93,spi-vsc7385)
 endef
 
 define KernelPackage/spi-vsc7385/description