[package] kernel: fix typo that prevents autoloading of the rdc321x_wdt driver
[openwrt.git] / package / kernel / modules / sound.mk
index 5146bf4693a3a5fad7389e2257806fe16690f182..fe1f3a63ca934d53bac8200ec0a929f9fcf01acc 100644 (file)
@@ -4,7 +4,6 @@
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 SOUND_MENU:=Sound Support
 
@@ -25,7 +24,8 @@ define KernelPackage/sound-core
        CONFIG_SND_SEQUENCER_OSS=y \
        CONFIG_HOSTAUDIO \
        CONFIG_SND_PCM_OSS \
-       CONFIG_SND_MIXER_OSS
+       CONFIG_SND_MIXER_OSS \
+       CONFIG_SOUND_OSS_CORE_PRECLAIM=y
 endef
 
 define KernelPackage/sound-core/2.4
@@ -96,9 +96,10 @@ $(eval $(call KernelPackage,sound-i8x0))
 define KernelPackage/sound-ps3
   SUBMENU:=$(SOUND_MENU)
   TITLE:=PS3 Audio
-  DEPENDS:=kmod-sound-core
+  DEPENDS:=kmod-sound-core @TARGET_ps3||@TARGET_ps3chk
   KCONFIG:=CONFIG_SND_PS3 \
-               CONFIG_SND_PPC
+               CONFIG_SND_PPC=y \
+               CONFIG_SND_PS3_DEFAULT_START_DELAY=2000
   FILES:=$(LINUX_DIR)/sound/ppc/snd_ps3.$(LINUX_KMOD_SUFFIX)
   AUTOLOAD:=$(call AutoLoad,35, snd_ps3)
 endef