kernel: move regmap bloat out of the kernel image if it is only being used in modules
[openwrt.git] / package / kernel / modules / sound.mk
index 3d12ba650ffaaa9f86a6339efc80593042c624d0..f80fa36c01e39d559c8b08805f6863da6c5cd9ba 100644 (file)
@@ -146,8 +146,10 @@ $(eval $(call KernelPackage,sound-cs5535audio))
 
 define KernelPackage/sound-soc-core
   TITLE:=SoC sound support
+  DEPENDS:=+kmod-regmap
   KCONFIG:= \
        CONFIG_SND_SOC \
+       CONFIG_SND_SOC_DMAENGINE_PCM=y \
        CONFIG_SND_SOC_ALL_CODECS=n
   FILES:=$(LINUX_DIR)/sound/soc/snd-soc-core.ko
   AUTOLOAD:=$(call AutoLoad,55, snd-soc-core)