package/kernel: use common gpio- & wdt- prefixes for GPIO and watchdog module names
[openwrt.git] / package / kernel / modules / sound.mk
index 5278e201f70ff9a4f6d2d596e6b775be417c5b76..ef6b0a9daf01fddf546188d6b548c69a25ed86cb 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2006-2008 OpenWrt.org
+# Copyright (C) 2006-2010 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -7,6 +7,22 @@
 
 SOUND_MENU:=Sound Support
 
+define KernelPackage/pcspkr
+  SUBMENU:=$(SOUND_MENU)
+  TITLE:=PC speaker support
+  DEPENDS:=@LINUX_2_6
+  KCONFIG:=CONFIG_INPUT_PCSPKR
+  FILES:=$(LINUX_DIR)/drivers/input/misc/pcspkr.$(LINUX_KMOD_SUFFIX)
+  AUTOLOAD:=$(call AutoLoad,50,pcspkr)
+endef
+
+define KernelPackage/pcspkr/description
+ This enables sounds (tones) through the pc speaker
+endef
+
+$(eval $(call KernelPackage,pcspkr))
+
+
 define KernelPackage/sound-core
   SUBMENU:=$(SOUND_MENU)
   TITLE:=Sound support
@@ -78,14 +94,14 @@ endef
 $(eval $(call KernelPackage,sound-core))
 
 
-define KernelPackage/sound/Depends
+define AddDepends/sound
   SUBMENU:=$(SOUND_MENU)
   DEPENDS:=kmod-sound-core $(1)
 endef
 
 
 define KernelPackage/sound-i8x0
-$(call KernelPackage/sound/Depends,@!TARGET_uml)
+$(call AddDepends/sound,@!TARGET_uml)
   TITLE:=Intel/SiS/nVidia/AMD/ALi AC97 Controller
   KCONFIG:=CONFIG_SND_INTEL8X0
   FILES:=$(LINUX_DIR)/sound/pci/snd-intel8x0.$(LINUX_KMOD_SUFFIX)
@@ -101,25 +117,8 @@ endef
 $(eval $(call KernelPackage,sound-i8x0))
 
 
-define KernelPackage/sound-ps3
-$(call KernelPackage/sound/Depends,@TARGET_ps3||TARGET_ps3chk)
-  TITLE:=PS3 Audio
-  KCONFIG:=CONFIG_SND_PS3 \
-               CONFIG_SND_PPC=y \
-               CONFIG_SND_PS3_DEFAULT_START_DELAY=2000
-  FILES:=$(LINUX_DIR)/sound/ppc/snd_ps3.$(LINUX_KMOD_SUFFIX)
-  AUTOLOAD:=$(call AutoLoad,35, snd_ps3)
-endef
-
-define KernelPackage/sound-ps3/description
- support for the integrated PS3 audio device
-endef
-
-$(eval $(call KernelPackage,sound-ps3))
-
-
 define KernelPackage/sound-cs5535audio
-$(call KernelPackage/sound/Depends,@!TARGET_uml)
+$(call AddDepends/sound,@!TARGET_uml)
   TITLE:=CS5535 PCI Controller
   KCONFIG:=CONFIG_SND_CS5535AUDIO
   FILES:=$(LINUX_DIR)/sound/pci/cs5535audio/snd-cs5535audio.$(LINUX_KMOD_SUFFIX) \
@@ -136,7 +135,7 @@ $(eval $(call KernelPackage,sound-cs5535audio))
 
 
 define KernelPackage/sound-soc-core
-$(call KernelPackage/sound/Depends)
+$(call AddDepends/sound)
   TITLE:=SoC sound support
   KCONFIG:= \
        CONFIG_SND_SOC \