package/kernel: add another round of missing bits from [21137] & [21138] (oops again)
[openwrt.git] / package / kernel / modules / netfilter.mk
index c8f8b1381d48bea4d331b735f265984f10a9c4b6..f499445144552edc065d2d27fd5159166d67e6ae 100644 (file)
@@ -1,6 +1,6 @@
 
 #
-# Copyright (C) 2006-2008 OpenWrt.org
+# Copyright (C) 2006-2010 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -21,25 +21,26 @@ endef
 define KernelPackage/ipt-core/description
  Netfilter core kernel modules
  Includes:
+ - comment (2.6)
  - limit
  - LOG
  - mac
  - multiport
- - TCPMSS
  - REJECT
+ - TCPMSS
 endef
 
 $(eval $(call KernelPackage,ipt-core))
 
 
-define KernelPackage/ipt/Depends
+define AddDepends/ipt
   SUBMENU:=$(NF_MENU)
   DEPENDS:= kmod-ipt-core $(1)
 endef
 
 
 define KernelPackage/ipt-conntrack
-$(call KernelPackage/ipt/Depends,)
+$(call AddDepends/ipt,)
   TITLE:=Basic connection tracking modules
   KCONFIG:=$(KCONFIG_IPT_CONNTRACK)
   FILES:=$(foreach mod,$(IPT_CONNTRACK-m),$(LINUX_DIR)/net/$(mod).$(LINUX_KMOD_SUFFIX))
@@ -49,6 +50,10 @@ endef
 define KernelPackage/ipt-conntrack/description
  Netfilter (IPv4) kernel modules for connection tracking
  Includes:
+ - conntrack
+ - defrag (2.6)
+ - iptables_raw
+ - NOTRACK
  - state
 endef
 
@@ -56,7 +61,7 @@ $(eval $(call KernelPackage,ipt-conntrack))
 
 
 define KernelPackage/ipt-conntrack-extra
-$(call KernelPackage/ipt/Depends,+kmod-ipt-conntrack)
+$(call AddDepends/ipt,+kmod-ipt-conntrack)
   TITLE:=Extra connection tracking modules
   KCONFIG:=$(KCONFIG_IPT_CONNTRACK_EXTRA)
   FILES:=$(foreach mod,$(IPT_CONNTRACK_EXTRA-m),$(LINUX_DIR)/net/$(mod).$(LINUX_KMOD_SUFFIX))
@@ -71,14 +76,13 @@ define KernelPackage/ipt-conntrack-extra/description
  - conntrack
  - helper
  - recent
- - NOTRACK
 endef
 
 $(eval $(call KernelPackage,ipt-conntrack-extra))
 
 
 define KernelPackage/ipt-filter
-$(call KernelPackage/ipt/Depends,+LINUX_2_6:kmod-textsearch)
+$(call AddDepends/ipt,+LINUX_2_6:kmod-textsearch)
   TITLE:=Modules for packet content inspection
   KCONFIG:=$(KCONFIG_IPT_FILTER)
   FILES:=$(foreach mod,$(IPT_FILTER-m),$(LINUX_DIR)/net/$(mod).$(LINUX_KMOD_SUFFIX))
@@ -88,15 +92,15 @@ endef
 define KernelPackage/ipt-filter/description
  Netfilter (IPv4) kernel modules for packet content inspection
  Includes:
- - ipt_layer7
- - ipt_string
+ - layer7
+ - string
 endef
 
 $(eval $(call KernelPackage,ipt-filter))
 
 
 define KernelPackage/ipt-ipopt
-$(call KernelPackage/ipt/Depends,)
+$(call AddDepends/ipt,)
   TITLE:=Modules for matching/changing IP packet options
   KCONFIG:=$(KCONFIG_IPT_IPOPT)
   FILES:=$(foreach mod,$(IPT_IPOPT-m),$(LINUX_DIR)/net/$(mod).$(LINUX_KMOD_SUFFIX))
@@ -106,21 +110,25 @@ endef
 define KernelPackage/ipt-ipopt/description
  Netfilter (IPv4) modules for matching/changing IP packet options
  Includes:
- - ipt_CLASSIFY
- - ipt_dscp/DSCP
- - ipt_ecn/ECN
- - ipt_length
- - ipt_tos/TOS
- - ipt_tcpmms
- - ipt_ttl/TTL
- - ipt_unclean
+ - CLASSIFY
+ - dscp/DSCP
+ - ecn/ECN
+ - hl/HL (2.6.30 and later)
+ - length
+ - mark/MARK
+ - statistic (2.6)
+ - tcpmss
+ - time
+ - tos/TOS (prior to 2.6.25)
+ - ttl/TTL (prior to 2.6.30)
+ - unclean
 endef
 
 $(eval $(call KernelPackage,ipt-ipopt))
 
 
 define KernelPackage/ipt-ipsec
-$(call KernelPackage/ipt/Depends,)
+$(call AddDepends/ipt,)
   TITLE:=Modules for matching IPSec packets
   KCONFIG:=$(KCONFIG_IPT_IPSEC)
   FILES:=$(foreach mod,$(IPT_IPSEC-m),$(LINUX_DIR)/net/$(mod).$(LINUX_KMOD_SUFFIX))
@@ -130,15 +138,16 @@ endef
 define KernelPackage/ipt-ipsec/description
  Netfilter (IPv4) modules for matching IPSec packets
  Includes:
- - ipt_ah
- - ipt_esp
+ - ah
+ - esp
+ - policy (2.6)
 endef
 
 $(eval $(call KernelPackage,ipt-ipsec))
 
 
 define KernelPackage/ipt-nat
-$(call KernelPackage/ipt/Depends,+kmod-ipt-conntrack)
+$(call AddDepends/ipt,+kmod-ipt-conntrack)
   TITLE:=Basic NAT targets
   KCONFIG:=$(KCONFIG_IPT_NAT)
   FILES:=$(foreach mod,$(IPT_NAT-m),$(LINUX_DIR)/net/$(mod).$(LINUX_KMOD_SUFFIX))
@@ -155,7 +164,7 @@ $(eval $(call KernelPackage,ipt-nat))
 
 
 define KernelPackage/ipt-nat-extra
-$(call KernelPackage/ipt/Depends,+kmod-ipt-nat)
+$(call AddDepends/ipt,+kmod-ipt-nat)
   TITLE:=Extra NAT targets
   KCONFIG:=$(KCONFIG_IPT_NAT_EXTRA)
   FILES:=$(foreach mod,$(IPT_NAT_EXTRA-m),$(LINUX_DIR)/net/$(mod).$(LINUX_KMOD_SUFFIX))
@@ -165,7 +174,7 @@ endef
 define KernelPackage/ipt-nat-extra/description
  Netfilter (IPv4) kernel modules for extra NAT targets
  Includes:
- - MIRROR
+ - MIRROR (2.4)
  - NETMAP
  - REDIRECT
 endef
@@ -174,7 +183,7 @@ $(eval $(call KernelPackage,ipt-nat-extra))
 
 
 define KernelPackage/ipt-nathelper
-$(call KernelPackage/ipt/Depends,+kmod-ipt-nat)
+$(call AddDepends/ipt,+kmod-ipt-nat)
   TITLE:=Basic Conntrack and NAT helpers
   KCONFIG:=$(KCONFIG_IPT_NATHELPER)
   FILES:=$(foreach mod,$(IPT_NATHELPER-m),$(LINUX_DIR)/net/$(mod).$(LINUX_KMOD_SUFFIX))
@@ -184,19 +193,16 @@ endef
 define KernelPackage/ipt-nathelper/description
  Default Netfilter (IPv4) Conntrack and NAT helpers
  Includes:
- - conntrack_ftp
- - nat_ftp
- - conntrack_irc
- - nat_irc
- - conntrack_tftp
- - nat_tftp
+ - ftp
+ - irc
+ - tftp
 endef
 
 $(eval $(call KernelPackage,ipt-nathelper))
 
 
 define KernelPackage/ipt-nathelper-extra
-$(call KernelPackage/ipt/Depends,+kmod-ipt-nat +LINUX_2_6:kmod-textsearch)
+$(call AddDepends/ipt,+kmod-ipt-nat +LINUX_2_6:kmod-textsearch)
   TITLE:=Extra Conntrack and NAT helpers
   KCONFIG:=$(KCONFIG_IPT_NATHELPER_EXTRA)
   FILES:=$(foreach mod,$(IPT_NATHELPER_EXTRA-m),$(LINUX_DIR)/net/$(mod).$(LINUX_KMOD_SUFFIX))
@@ -206,21 +212,21 @@ endef
 define KernelPackage/ipt-nathelper-extra/description
  Extra Netfilter (IPv4) Conntrack and NAT helpers
  Includes:
- - ip_conntrack_amanda
- - ip_conntrack_proto_gre
- - ip_nat_proto_gre
- - ip_conntrack_pptp
- - ip_nat_pptp
- - ip_conntrack_sip
- - ip_nat_sip
- - ip_nat_snmp_basic
+ - amanda
+ - h323
+ - mms
+ - pptp (2.6)
+ - proto_gre (2.6)
+ - rtsp
+ - sip (2.6)
+ - snmp_basic
 endef
 
 $(eval $(call KernelPackage,ipt-nathelper-extra))
 
 
 define KernelPackage/ipt-imq
-$(call KernelPackage/ipt/Depends,)
+$(call AddDepends/ipt,)
   TITLE:=Intermediate Queueing support
   KCONFIG:= \
        CONFIG_IMQ \
@@ -244,7 +250,7 @@ $(eval $(call KernelPackage,ipt-imq))
 
 
 define KernelPackage/ipt-queue
-$(call KernelPackage/ipt/Depends,)
+$(call AddDepends/ipt,)
   TITLE:=Module for user-space packet queueing
   KCONFIG:=$(KCONFIG_IPT_QUEUE)
   FILES:=$(foreach mod,$(IPT_QUEUE-m),$(LINUX_DIR)/net/$(mod).$(LINUX_KMOD_SUFFIX))
@@ -261,7 +267,7 @@ $(eval $(call KernelPackage,ipt-queue))
 
 
 define KernelPackage/ipt-ulog
-$(call KernelPackage/ipt/Depends,)
+$(call AddDepends/ipt,)
   TITLE:=Module for user-space packet logging
   KCONFIG:=$(KCONFIG_IPT_ULOG)
   FILES:=$(foreach mod,$(IPT_ULOG-m),$(LINUX_DIR)/net/$(mod).$(LINUX_KMOD_SUFFIX))
@@ -271,14 +277,14 @@ endef
 define KernelPackage/ipt-ulog/description
  Netfilter (IPv4) module for user-space packet logging
  Includes:
- - ipt_ULOG
+ - ULOG
 endef
 
 $(eval $(call KernelPackage,ipt-ulog))
 
 
 define KernelPackage/ipt-iprange
-$(call KernelPackage/ipt/Depends,)
+$(call AddDepends/ipt,)
   TITLE:=Module for matching ip ranges
   KCONFIG:=$(KCONFIG_IPT_IPRANGE)
   FILES:=$(foreach mod,$(IPT_IPRANGE-m),$(LINUX_DIR)/net/$(mod).$(LINUX_KMOD_SUFFIX))
@@ -288,14 +294,14 @@ endef
 define KernelPackage/ipt-iprange/description
  Netfilter (IPv4) module for matching ip ranges
  Includes:
- - ipt_IPRANGE
+ - iprange
 endef
 
 $(eval $(call KernelPackage,ipt-iprange))
 
 
 define KernelPackage/ipt-extra
-$(call KernelPackage/ipt/Depends,)
+$(call AddDepends/ipt,)
   TITLE:=Extra modules
   KCONFIG:=$(KCONFIG_IPT_EXTRA)
   FILES:=$(foreach mod,$(IPT_EXTRA-m),$(LINUX_DIR)/net/$(mod).$(LINUX_KMOD_SUFFIX))
@@ -305,12 +311,11 @@ endef
 define KernelPackage/ipt-extra/description
  Other Netfilter (IPv4) kernel modules
  Includes:
- - ipt_owner
- - ipt_physdev
- - ipt_pkttype
- - ipt_recent
- - iptable_raw
- - xt_NOTRACK
+ - condition (2.4 only)
+ - owner
+ - physdev (if bridge support was enabled in kernel)
+ - pkttype
+ - quota
 endef
 
 $(eval $(call KernelPackage,ipt-extra))
@@ -368,14 +373,14 @@ endef
 $(eval $(call KernelPackage,ebtables))
 
 
-define KernelPackage/ebtables/Depends
+define AddDepends/ebtables
   SUBMENU:=$(NF_MENU)
   DEPENDS:=kmod-ebtables $(1)
 endef
 
 
 define KernelPackage/ebtables-ipv4
-$(call KernelPackage/ebtables/Depends,)
+$(call AddDepends/ebtables,)
   TITLE:=ebtables: IPv4 support
   FILES:=$(foreach mod,$(EBTABLES_IP4-m),$(LINUX_DIR)/net/$(mod).$(LINUX_KMOD_SUFFIX))
   KCONFIG:=$(KCONFIG_EBTABLES_IP4)
@@ -391,7 +396,7 @@ $(eval $(call KernelPackage,ebtables-ipv4))
 
 
 define KernelPackage/ebtables-ipv6
-$(call KernelPackage/ebtables/Depends,)
+$(call AddDepends/ebtables,)
   TITLE:=ebtables: IPv6 support
   FILES:=$(foreach mod,$(EBTABLES_IP6-m),$(LINUX_DIR)/net/$(mod).$(LINUX_KMOD_SUFFIX))
   KCONFIG:=$(KCONFIG_EBTABLES_IP6)
@@ -407,7 +412,7 @@ $(eval $(call KernelPackage,ebtables-ipv6))
 
 
 define KernelPackage/ebtables-watchers
-$(call KernelPackage/ebtables/Depends,)
+$(call AddDepends/ebtables,)
   TITLE:=ebtables: watchers support
   FILES:=$(foreach mod,$(EBTABLES_WATCHERS-m),$(LINUX_DIR)/net/$(mod).$(LINUX_KMOD_SUFFIX))
   KCONFIG:=$(KCONFIG_EBTABLES_WATCHERS)
@@ -438,14 +443,14 @@ endef
 $(eval $(call KernelPackage,nfnetlink))
 
 
-define KernelPackage/nfnetlink/Depends
+define AddDepends/nfnetlink
   SUBMENU:=$(NF_MENU)
   DEPENDS:=@LINUX_2_6 +kmod-nfnetlink $(1)
 endef
 
 
 define KernelPackage/nfnetlink-log
-$(call KernelPackage/nfnetlink/Depends,)
+$(call AddDepends/nfnetlink,)
   TITLE:=Netfilter LOG over NFNETLINK interface
   FILES:=$(LINUX_DIR)/net/netfilter/nfnetlink_log.$(LINUX_KMOD_SUFFIX)
   KCONFIG:=CONFIG_NETFILTER_NETLINK_LOG
@@ -460,7 +465,7 @@ $(eval $(call KernelPackage,nfnetlink-log))
 
 
 define KernelPackage/nfnetlink-queue
-$(call KernelPackage/nfnetlink/Depends,)
+$(call AddDepends/nfnetlink,)
   TITLE:=Netfilter QUEUE over NFNETLINK interface
   FILES:=$(LINUX_DIR)/net/netfilter/nfnetlink_queue.$(LINUX_KMOD_SUFFIX)
   KCONFIG:=CONFIG_NETFILTER_NETLINK_QUEUE
@@ -475,7 +480,7 @@ $(eval $(call KernelPackage,nfnetlink-queue))
 
 
 define KernelPackage/nf-conntrack-netlink
-$(call KernelPackage/nfnetlink/Depends,+kmod-ipt-conntrack)
+$(call AddDepends/nfnetlink,+kmod-ipt-conntrack)
   TITLE:=Connection tracking netlink interface
   FILES:=$(LINUX_DIR)/net/netfilter/nf_conntrack_netlink.$(LINUX_KMOD_SUFFIX)
   KCONFIG:=CONFIG_NF_CT_NETLINK