[packages] kernel: Add hwmon-lm63 package
[openwrt.git] / package / kernel / modules / netfilter.mk
index 561286efda7f2f44319538919940f6f1647c7b89..e2361af6ae7bd27a6bb41602a2de7a3197f14800 100644 (file)
@@ -13,7 +13,10 @@ include $(INCLUDE_DIR)/netfilter.mk
 define KernelPackage/ipt-core
   SUBMENU:=$(NF_MENU)
   TITLE:=Netfilter core
-  KCONFIG:=$(KCONFIG_IPT_CORE)
+  KCONFIG:= \
+       CONFIG_NETFILTER=y \
+       CONFIG_NETFILTER_ADVANCED=y \
+       $(KCONFIG_IPT_CORE)
   FILES:=$(foreach mod,$(IPT_CORE-m),$(LINUX_DIR)/net/$(mod).ko)
   AUTOLOAD:=$(call AutoLoad,40,$(notdir $(IPT_CORE-m)))
 endef
@@ -512,3 +515,18 @@ define KernelPackage/nf-conntrack-netlink/description
 endef
 
 $(eval $(call KernelPackage,nf-conntrack-netlink))
+
+define KernelPackage/ipt-hashlimit
+  SUBMENU:=$(NF_MENU)
+  TITLE:=Netfilter hashlimit match
+  KCONFIG:=$(KCONFIG_IPT_HASHLIMIT)
+  FILES:=$(LINUX_DIR)/net/netfilter/xt_hashlimit.ko
+  AUTOLOAD:=$(call AutoLoad,50,xt_hashlimit)
+  $(call KernelPackage/ipt)
+endef
+
+define KernelPackage/ipt-hashlimit/description
+ Kernel modules support for the hashlimit bucket match module
+endef
+
+$(eval $(call KernelPackage,ipt-hashlimit))