package/kernel: add dependency on kmod-input-core to kmod-sound-core (closes: #7140)
[openwrt.git] / package / kernel / modules / netfilter.mk
index c8f8b1381d48bea4d331b735f265984f10a9c4b6..d19a16da3f93fcea4b505c64423f5d3b6f473962 100644 (file)
@@ -21,12 +21,13 @@ endef
 define KernelPackage/ipt-core/description
  Netfilter core kernel modules
  Includes:
+ - comment (2.6)
  - limit
  - LOG
  - mac
  - multiport
- - TCPMSS
  - REJECT
+ - TCPMSS
 endef
 
 $(eval $(call KernelPackage,ipt-core))
@@ -49,6 +50,10 @@ endef
 define KernelPackage/ipt-conntrack/description
  Netfilter (IPv4) kernel modules for connection tracking
  Includes:
+ - conntrack
+ - defrag (2.6)
+ - iptables_raw
+ - NOTRACK
  - state
 endef
 
@@ -71,7 +76,6 @@ define KernelPackage/ipt-conntrack-extra/description
  - conntrack
  - helper
  - recent
- - NOTRACK
 endef
 
 $(eval $(call KernelPackage,ipt-conntrack-extra))
@@ -88,8 +92,8 @@ endef
 define KernelPackage/ipt-filter/description
  Netfilter (IPv4) kernel modules for packet content inspection
  Includes:
- - ipt_layer7
- - ipt_string
+ - layer7
+ - string
 endef
 
 $(eval $(call KernelPackage,ipt-filter))
@@ -106,14 +110,18 @@ endef
 define KernelPackage/ipt-ipopt/description
  Netfilter (IPv4) modules for matching/changing IP packet options
  Includes:
- - ipt_CLASSIFY
- - ipt_dscp/DSCP
- - ipt_ecn/ECN
- - ipt_length
- - ipt_tos/TOS
- - ipt_tcpmms
- - ipt_ttl/TTL
- - ipt_unclean
+ - CLASSIFY
+ - dscp/DSCP
+ - ecn/ECN
+ - hl/HL (2.6.30 and later)
+ - length
+ - mark/MARK
+ - statistic (2.6)
+ - tcpmss
+ - time
+ - tos/TOS (prior to 2.6.25)
+ - ttl/TTL (prior to 2.6.30)
+ - unclean
 endef
 
 $(eval $(call KernelPackage,ipt-ipopt))
@@ -130,8 +138,9 @@ endef
 define KernelPackage/ipt-ipsec/description
  Netfilter (IPv4) modules for matching IPSec packets
  Includes:
- - ipt_ah
- - ipt_esp
+ - ah
+ - esp
+ - policy (2.6)
 endef
 
 $(eval $(call KernelPackage,ipt-ipsec))
@@ -165,7 +174,7 @@ endef
 define KernelPackage/ipt-nat-extra/description
  Netfilter (IPv4) kernel modules for extra NAT targets
  Includes:
- - MIRROR
+ - MIRROR (2.4)
  - NETMAP
  - REDIRECT
 endef
@@ -184,12 +193,9 @@ endef
 define KernelPackage/ipt-nathelper/description
  Default Netfilter (IPv4) Conntrack and NAT helpers
  Includes:
- - conntrack_ftp
- - nat_ftp
- - conntrack_irc
- - nat_irc
- - conntrack_tftp
- - nat_tftp
+ - ftp
+ - irc
+ - tftp
 endef
 
 $(eval $(call KernelPackage,ipt-nathelper))
@@ -206,14 +212,14 @@ endef
 define KernelPackage/ipt-nathelper-extra/description
  Extra Netfilter (IPv4) Conntrack and NAT helpers
  Includes:
- - ip_conntrack_amanda
- - ip_conntrack_proto_gre
- - ip_nat_proto_gre
- - ip_conntrack_pptp
- - ip_nat_pptp
- - ip_conntrack_sip
- - ip_nat_sip
- - ip_nat_snmp_basic
+ - amanda
+ - h323
+ - mms
+ - pptp (2.6)
+ - proto_gre (2.6)
+ - rtsp
+ - sip (2.6)
+ - snmp_basic
 endef
 
 $(eval $(call KernelPackage,ipt-nathelper-extra))
@@ -271,7 +277,7 @@ endef
 define KernelPackage/ipt-ulog/description
  Netfilter (IPv4) module for user-space packet logging
  Includes:
- - ipt_ULOG
+ - ULOG
 endef
 
 $(eval $(call KernelPackage,ipt-ulog))
@@ -288,7 +294,7 @@ endef
 define KernelPackage/ipt-iprange/description
  Netfilter (IPv4) module for matching ip ranges
  Includes:
- - ipt_IPRANGE
+ - iprange
 endef
 
 $(eval $(call KernelPackage,ipt-iprange))
@@ -305,12 +311,11 @@ endef
 define KernelPackage/ipt-extra/description
  Other Netfilter (IPv4) kernel modules
  Includes:
- - ipt_owner
- - ipt_physdev
- - ipt_pkttype
- - ipt_recent
- - iptable_raw
- - xt_NOTRACK
+ - condition (2.4 only)
+ - owner
+ - physdev (if bridge support was enabled in kernel)
+ - pkttype
+ - quota
 endef
 
 $(eval $(call KernelPackage,ipt-extra))