[package] kernel: fix typo that prevents autoloading of the rdc321x_wdt driver
[openwrt.git] / package / kernel / modules / hwmon.mk
index 3dd3f4ceb6a8d3bbd8dfa2967556905906f42215..f259a7af93a455a21ebff453a102a6fa01ece528 100644 (file)
@@ -4,7 +4,6 @@
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 HWMON_MENU:=Hardware Monitoring Support
 
@@ -14,12 +13,10 @@ define KernelPackage/hwmon-core
   DEPENDS:=@LINUX_2_6
   KCONFIG:= \
        CONFIG_HWMON \
-       CONFIG_HWMON_VID \
        CONFIG_HWMON_DEBUG_CHIP=n
   FILES:= \
-       $(LINUX_DIR)/drivers/hwmon/hwmon.$(LINUX_KMOD_SUFFIX) \
-       $(LINUX_DIR)/drivers/hwmon/hwmon-vid.$(LINUX_KMOD_SUFFIX)
-  AUTOLOAD:=$(call AutoLoad,40,hwmon hwmon-vid)
+       $(LINUX_DIR)/drivers/hwmon/hwmon.$(LINUX_KMOD_SUFFIX)
+  AUTOLOAD:=$(call AutoLoad,40,hwmon)
 endef
 
 define KernelPackage/hwmon-core/description
@@ -29,29 +26,63 @@ endef
 $(eval $(call KernelPackage,hwmon-core))
 
 
+define KernelPackage/hwmon-lm75
+  SUBMENU:=$(HWMON_MENU)
+  TITLE:=LM75 monitoring support
+  DEPENDS:=kmod-hwmon-core +kmod-i2c-core
+  KCONFIG:=CONFIG_SENSORS_LM75
+  FILES:=$(LINUX_DIR)/drivers/hwmon/lm75.$(LINUX_KMOD_SUFFIX)
+  AUTOLOAD:=$(call AutoLoad,60,lm75)
+endef
+
+define KernelPackage/hwmon-lm75/description
+ Kernel module for lm75 thermal monitor chip
+endef
+
+$(eval $(call KernelPackage,hwmon-lm75))
+
+
 define KernelPackage/hwmon-lm77
   SUBMENU:=$(HWMON_MENU)
   TITLE:=LM77 monitoring support
-  DEPENDS:=kmod-hwmon-core
+  DEPENDS:=kmod-hwmon-core +kmod-i2c-core
   KCONFIG:=CONFIG_SENSORS_LM77
   FILES:=$(LINUX_DIR)/drivers/hwmon/lm77.$(LINUX_KMOD_SUFFIX)
   AUTOLOAD:=$(call AutoLoad,60,lm77)
 endef
+
 define KernelPackage/hwmon-lm77/description
- Kernel module for LM77 thermal monitor chip 
+ Kernel module for LM77 thermal monitor chip
 endef
 
 $(eval $(call KernelPackage,hwmon-lm77))
 
+define KernelPackage/hwmon-lm90
+  SUBMENU:=$(HWMON_MENU)
+  TITLE:=LM90 monitoring support
+  DEPENDS:=kmod-hwmon-core +kmod-i2c-core
+  KCONFIG:=CONFIG_SENSORS_LM90
+  FILES:=$(LINUX_DIR)/drivers/hwmon/lm90.$(LINUX_KMOD_SUFFIX)
+  AUTOLOAD:=$(call AutoLoad,60,lm90)
+endef
+
+define KernelPackage/hwmon-lm90/description
+ Kernel module for LM90 thermal monitor chip
+endef
+
+$(eval $(call KernelPackage,hwmon-lm90))
 
 define KernelPackage/hwmon-pc87360
   SUBMENU:=$(HWMON_MENU)
   TITLE:=PC87360 monitoring support
-  DEPENDS:=kmod-hwmon-core
-  KCONFIG:=CONFIG_SENSORS_PC87360
-  FILES:=$(LINUX_DIR)/drivers/hwmon/pc87360.$(LINUX_KMOD_SUFFIX)
-  AUTOLOAD:=$(call AutoLoad,50,pc87360)
+  DEPENDS:=kmod-hwmon-core @TARGET_x86
+  KCONFIG:= \
+       CONFIG_SENSORS_PC87360 \
+       CONFIG_HWMON_VID
+  FILES:= \
+       $(LINUX_DIR)/drivers/hwmon/hwmon-vid.$(LINUX_KMOD_SUFFIX) \
+       $(LINUX_DIR)/drivers/hwmon/pc87360.$(LINUX_KMOD_SUFFIX)
+  AUTOLOAD:=$(call AutoLoad,50,hwmon-vid pc87360)
 endef
 
 define KernelPackage/hwmon-pc87360/description
@@ -60,3 +91,21 @@ endef
 
 $(eval $(call KernelPackage,hwmon-pc87360))
 
+define KernelPackage/hwmon-w83627hf
+  SUBMENU:=$(HWMON_MENU)
+  TITLE:=Winbond W83627HF monitoring support
+  DEPENDS:=kmod-hwmon-core @TARGET_x86||TARGET_rdc
+  KCONFIG:= \
+       CONFIG_SENSORS_W83627HF \
+       CONFIG_HWMON_VID
+  FILES:= \
+       $(LINUX_DIR)/drivers/hwmon/hwmon-vid.$(LINUX_KMOD_SUFFIX) \
+       $(LINUX_DIR)/drivers/hwmon/w83627hf.$(LINUX_KMOD_SUFFIX)
+  AUTOLOAD:=$(call AutoLoad,50,hwmon-vid w83627h)
+endef
+
+define KernelPacakge/hwmon-w83627hf/description
+  Kernel module for the Winbond W83627HF chips.
+endef
+
+$(eval $(call KernelPackage,hwmon-w83627hf))